Forum Index > Washer Repair

Kenmore 80 series issues after installing coupler

(1/3) > >>

My machine worked fine, then broke the coupler. I took the machine apart, replaced the coupler, and upon putting it back together had a really bad rubber burning smell. Suspecting that the coupler was not fit flush on the shaft, I took the machine back apart and made the coupler flush by knocking it on with a nut driver as suggested here.

I put the machine back together and it will fill, then nothing until it goes all the way to the spin cyle where it will spin out. It never agitates, or even attempt to try and agitate. I have taken it back apart and checked all connections, the lid switch is good, nothing outwardly obvious as to why it suddenly will not agitate, when it worked fine just moments before.

What do I need to check?


Model 110.29882890

While fiddling with the machine you may have made the timer connection get a little bit loose or you might have pinched the plastic tube from the tub up to the  water level switch so check all that.

Al Capone:
Hi punkncat,

Could you post the model number for us? The model number can be found on the model/serial number tag that is located on the washer.

Check picture below for possible model number tag locations.

Thanks for posting your questions.

k, all seems fine, what next?

You need to get everything back off you have something binding


[0] Message Index

[#] Next page

Go to full version