Forum Index > Range, Oven & Cooktop Repair

GE oven not heating properly

(1/3) > >>

Hi, I have a GE range and the oven is not heating properly.  I baked a meatloaf last night and it took too long for the meat to get to the proper temp.  Today, I tried to bake a pizza at 400 (just like last Friday) and the pizza looked like it had only been in for about 2 minutes at the 13 min mark.  I turned up the temp to 450 and the cheese began to melt and brown after about 10 min, but the bottom of the pizza was still rubbery and uncooked.  When I open the oven, I do not feel the heat like I used to.  Also, only the top of the pizza showed signs of heat, not the bottom.  Any ideas?  This oven is 20 years old this month.

Model JSC27GJ

well your bake element is either gonna be good or bad no in between. If it broils ok then your breaker probably is fine. Must be the oven control.

What is the oven control?  I'm looking for the part at

I tried looking up your model number at repairclinic, but it seems you are missing some numbers.

Could you double check the model number?
Look at the model/serial number tag on the oven for the complete model number.

--- Quote ---What is the oven control?
--- End quote ---

Should look something like this.

JSC27G0J4BG is the serial number


[0] Message Index

[#] Next page

Go to full version