Forum Index > Range, Oven & Cooktop Repair

Electic Oven - No Heat

(1/2) > >>

Turned the oven on the other day and no heat.  Tried broil ... no heat.  All stove top burners work fine.  Used to when the oven was started a heating light would come on and relay clicks could be heard.  Now the light comes on and no relay clicks.  Elements seem good.  Is the control board faulty?  Any other causes?

Model Number: rf378pxgw

Probaby but check the breaker and receptacle before buying exspensive controls.

See this post:;topicseen#new

Since the burners work fine I don't think it is a plug or breaker issue.  I have flipped the breaker a few times and well as unplugged the appliance and plugged it back in.

With regards to other thread the model I have does not seem to have any fuse or overtemp thermostat.

I ordered a replacement elec-cntrl yesterday and should have it in late this week or early next.

Over the weekend I tried the self clean function.  Everything appeared to be working correctly just no heat.  The door locked, door locked light came on, timer worked ... just no heat.  Although it was not visually recognizable I just think something on the board is smoked.

Got the new controls and fixed everything.  Prior to purchasing I took the back off and made sure no wires were burnt.  The stove top burners worked, all the lights, timers appeared to be working fine.  I even ran the clean feature and it locked and unlocked the door and the heating light illuminated.  Just no heat to either burner and no audible click from the relays.  Thanks for your help and I hope that this will help someone else.


[0] Message Index

[#] Next page

Go to full version