Forum Index > Refrigerator & Freezer Repair

1975 GE Refrigerator not cooling


My GE fridge has suddenly quit cooling.  Lights on, freezer fan on, refrigerator fan on, defrost timer spinning.  Compressor not running; external compressor fan not running.

There does not seem to be a start relay.  Only two terminals to the compressor.  No clicking sounds upon plugging in the unit.

Is there anything I can reasonably test with a V-O-M?

The unit is a Model TBF18DRR purchased in 1975, but I cannot find any internet listing for parts or diagrams.


Dean Park
St. Louis, MO

Well, the compressor had or has a start relay at one time along with an overload, shows the relay is NLA,CLICK HERE this is what starts the compressor, unit is too old to bring up a parts diagram at condensor fan motor runs on these friges thru the relay or the windings on in the compressor, cannot remember you have either lost the voltage to the compressor or the compressor itself is bad or the overload on the compressor is open.....need to see if you do have voltage to the compressor or not, if the fan in the freezer is runnning the compressor should be running also...might check that overload to see if it is burnt out, this would cut the power to the compressor...

Thanks for the help.  You were right.  There is a start relay.  I just needed more light to see it.

I checked voltage on the relay, and found it to be zero.  That led me to believe it was simply the guardette that was also stuffed into the relay cover.  I bypassed the guardette and the unit started, sort of.  The evaporator fan started turning and the compressor attempted to start. The light on the same circuit as the fridge got dim, then the circuit breaker tripped.  Tried this a couple of times with the same result.

I tried to reach down and touch the compressor to see if it was running, but not enough time before the circuit breaker tripped.

So, I know I have a faulty guardette, along with something else.

I'm guessing it to be one of three things:

1.  Bad compressor
2.  Bad start relay, not moving from start to run; or only going to run.
3.  Both

There are no shorts from the three pins on the compressor to case ground.

Any suggestions?

Thanks, again.

Dean Park

well with this popping your house breaker I am leaning toward something bad wrong with the compressor, perhaps shorted windings, and since the relay is NLA you are about down to trying a supco 2 in 1 or 3 in 1 as a test..might be a waste of money, may not.... :embarassed:

Thanks again.  I'm going to buy an RO410 and give it a try.

Dean Park


[0] Message Index

Go to full version