Get Answers to your Appliance Repair Questions

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: LG Gas Dryer DLG2524W Error code 19:HO / U01: Unit spins, but no heat. Help?  (Read 7949 times)

Offline basnap

  • VIP Member
  • Member Since: Apr 2014
  • Posts: 8

Hi All,

Just got married and the wife is pissed already... Dryer stopped heating on any program overnight. The unit is a GAS powered 7 y/o LG DLG2524W. Nothing changed/moved. It spins, completes all programs but it simply does not heat.

There is enough ventilation, no lint in the filter, no clogging etc. Gas is connected and source pipe goes to water heater too which does work

Found the service manual here: DLG2524W Service Manual

It lists some self tests (press 'more/less time' icw 'power'). Then you hit START button a couple of times for different tests, but it never gets that far. Mine circles between 19:H0 and U01 and that's it. Nothing happens when I hit START to perform the other tests. Obviously this error code isNOT listed in the manual.

Found one post where it turned out to be a faulty flameswitch flame switch/sensor

Found another one where the main board was suspected (unconfirmed) Faulty board?

I've opened the unit & performed the following tests:

1) Measured thermostat (M220) and hi limit thermostat (M230) both showed 0 Ohm -> Should be OK
2) Based on 'Gas valve test'* I replaced the M230 but no change
3) Measure resistance of ignitor and flame sensor, both are 0 Ohm -> should be OK
4) Measured resistance of both GAS valve coils (disconnect terminals), both are in the 1150-1180 Ohm -> should be OK

Removed the front panel which holds the door while leaving DOOR switch connected. The drum is still in place and can rotate. And indeed, if I start the unit it will spin. The ignitor will glow deep orange for a few seconds before switching off again, it tries again in a couple of minutes but the gas never fires. I do not hear any clicks on the GAS valves.

This is someone's video where you see how the firing sequence works, but in his case the gas keeps flowing with ignitor off, which is very dangerous. Hard to judge by the video, but his ignitor seems whiter, whereas mine is a deep yellow/orange.

I measured the voltage in both AC and DC (the manual/forums are unclear on AC or DC) of the 2 terminals connecting to the GAS VALVES and I never get above 1 volt. Disconnecting mains will bring this to 0 completely.

Some questions I had.
1) What/who controls the voltage on these terminals?

2) At what stage to expect the voltage to be [ 40 - 90 Volts AC/DC ]?

a) With the unit plugged in but not powered up?
b) With the unit powered up but no program selected
c) When a program is running
d) When a program is running and the ignitor glows?
e) With a program running with actual wet clothes in the dryer such that the moisture sensor detects wetness?

I've measured the power going to VALVE 1 when running a program. Valve 2 is harder to get to but I suppose I could disconnect it. VALVE 1 does show slight voltage change when the ignitor lits up, but again, never reaches anywhere near the 40 - 90 volts I am guessing it needs?

Similar issues with slighty different variations:
Board Defect

Board replacement didn't resolve

Unstable hi limit thermostat

Burner sequence, suggesting 90V should be measurable at coils

Poster also looking for more detailed sequence of what should be measuring at what point

Getting only 20 V on the coils

Long chat, same symptoms, guy replaced board but still 50V

Sorry for this lenghty post. I hope someone can give me some hints. I am suspecting a bad board at this point ($100) but would like to test some more.

Thanks & I will post once resolved

Offline tgoods

  • Technician
  • Member Since: Jul 2010
  • Posts: 1831
  • Country: us
    • Buy me a beer through paypal
Check the wiring between the valve solenoids and the control for continuity. If it checks good, replace the control board.

Offline basnap

  • VIP Member
  • Member Since: Apr 2014
  • Posts: 8

I had done that actually just after the post. from the control board there is one plug with 3 wires, a white, a red and a purple wire.

VALVE1 gets the RED and PURPLE plugs

All wires check fine between the COILS and control board.

So next stop... control board....

Offline domain

  • Technician
  • Member Since: Nov 2012
  • Posts: 2610
  • Country: us
    • Buy me a beer through paypal
Agreed on pcb. We do not have many gas appliances around here, so I do my bestest.  O0

Offline basnap

  • VIP Member
  • Member Since: Apr 2014
  • Posts: 8
I performed one more test. With most of the dryer back together and just the toppanel and the controls not mounted, I ran the dryer while having the plug disconnected facing the 2 GAS VALCES.

I put a volt meter and measured both AC and DC (again, manual says DC but some forums say AC). I do get like .4x Volte and see maybe a small increase when the ignitor glows (which I could see because the top was off).

Hence, the control board doesn't fire to open the valves...  but does that mean control board is bad?

Not in my view... it still could be that *some* sensor tells the control board not to fire because *some* condition is not met.

I did order the part though..

Checked here:

For my specs (LG, dryer, DLG2524W) and order it off repair clinic. It was a couple of $ more, but since their return policy is great I decided to go with them.

Will keep this thread going till this is resolved satisfactory

Offline domain

  • Technician
  • Member Since: Nov 2012
  • Posts: 2610
  • Country: us
    • Buy me a beer through paypal
I am 95% sure it is 90 vDC to coils. O0 O0

Offline basnap

  • VIP Member
  • Member Since: Apr 2014
  • Posts: 8
Hi All,

The control board came in, shipped with FedEX and packaged well. It looked the same unit but when I removed the unit from the dryer I was in for a surprise. The newer model is MISSING certain plugs, most notable the 2 for the sensors/thermostat!

I had ordered this unit but my old unit is this one

It turns out that 6871EC1121D was replaced with 6871EC1121A: (The manufacturer or RepairClinic has replaced part number 6871ec1121d with this item, part number 6871EC1121A.)


The newer unit does NOT have plug BL3 NOR the plug for the fire sensor / thermostat but it DOES have an 4 pin extra plug underneath the transformer (no current connector would go connect to that.

Plug BL3 is the EXACT plug I had measured before and it's the one leading to the GAS VALVES. (recall, I was not getting any voltage on the coils so they'd never open).

These are the pins I expect +90 volts on to actually open the GAS VALVES

I fail to see how the valves would ever open when the control plug is not going to be connected on the new board?

I found another website showing the the A part replaces the D part:

I tried there online help:

Chatted with Susan
[Visitor] How are you?
[Visitor] I am looking at this part 6871EC1121A
[Visitor] It replaces this part: 6871EC1121D
[Susan] Good, thanks!
[Visitor] but 6871EC1121D has more plugs
[Susan] Just a minute please.
[Visitor] where does the connector to open the valves get connected to? How will the valves ever open?
[Susan] This part # 6871EC1121A is listed as the proper replacement for part # 6871EC1121D.
[Susan] I do not have any more information than that.

Anyone seen this before? Return it another the Amazon 'D' model?

Offline bagjr387

  • Technician
  • Member Since: Apr 2014
  • Posts: 72
I know you went through a bunch of stuff already, sometimes those burner coils can ohm fine, but then when they heat up, they can stop working. If the ignitor glows, and then goes out, its a sign that the coils are weak and need to be replaced. If the ignitor is glowing, then there is power to the gas valve. Unless LG does something way different then other manufacturers, The ignitor is in series with the flame sensor and the burner coils. A glowing ignitor would mean the computer should be fine (unless LG is way different)

Offline john63

  • Technician
  • Member Since: Feb 2010
  • Posts: 573
<<<It lists some self tests (press 'more/less time' icw 'power'). Then you hit START button a couple of times for different tests, but it never gets that far. Mine circles between 19:H0 and U01 and that's it.>>>


Software Version Number/Check Digits (normal)


 <<<Nothing happens when I hit START to perform the other tests.>>>


If the TEST MODE will not advance beyond the initial Software Version displayed---failed Main Board.

Correct Main Board is (6871EC1121D) for the LG gas dryer model DLG2524W

The Main Board part number 6871EC1121A is for an LG *electric* dryer model DLE5977

Offline basnap

  • VIP Member
  • Member Since: Apr 2014
  • Posts: 8
@john63: Now that would make sense doesn't it? The electric version would not need to control the gas valves!!!  :) That said, several sites have the 'A' model listed as the replacement for the 'D' model.

@bagjr387: I agree with your assessment, however I was never able to measure any voltage going to the coils. They Ohmed out OK, but never received a voltage. Which leads me to believe that the controller is bad OR that another sensor prevents the controller putting any voltage on...

Ordered the 'D' piece of amazon. Will update once I install it.


Whirlpool Steam Dryer F23 Error Code

Started by TechnicianBrian

Replies: 2
Views: 12971
Last post April 25, 2008, 08:25:02 PM
by TechnicianBrian
Error code 40 on Oasis Elite Dryer

Started by MWCmike

Replies: 3
Views: 7915
Last post September 16, 2008, 03:36:21 PM
by Repair-man
Electric Dryer LEQ2152ES0 not heating error code e56

Started by DeeStough

Replies: 11
Views: 21926
Last post February 23, 2011, 12:06:45 AM
by AJ
70 series Kenmore electric dryer spins but does not heat

Started by llew_x

Replies: 52
Views: 85551
Last post July 23, 2013, 08:25:04 AM
by JWWebster
Frigidaire Front Load Dryer Error Code DR

Started by sharitac

Replies: 6
Views: 23051
Last post April 26, 2009, 09:07:40 AM
by JWWebster
LG electric dryer spins no heat

Started by brockinfla

Replies: 3
Views: 8755
Last post May 20, 2009, 12:08:41 AM
by PARTech