Forum Index > Washer Repair

Whirlpool Duet front load washer error code FH

(1/4) > >>

Model GWH9150PWO:
When my wife started a cycle, it initially added water, but after about 10 minutes, the cycle had stopped and it was displaying the FH error code (apparently after the second time in the cycle when it adds water).  Subsequent attempts to run a cycle did not add ANY water, and would display the FH code within a minute or so.

I verified the water supply valves are on, the inlet screens are clean, and the pump strainer/filter is clean.

I ran the diagnostic test, and at Step C:01 (tests flowmeter and cold water inlet valve), the test displayed code FH.  I restarted the test and skipped over this step so the rest of the tests could be run.  It next stopped at C:03 (tests hot water inlet valve)--FH code.  I restarted and skipped past C:03, and it stopped at C:05 (test heater if present (not on mine), and if there is not enough water in the tub, it adds water)--FH code.  I restarted and skipped past C:05 and it completed the remainder of the diagnostic tests with no error messages.  Since the only steps flagged were those where water was supposed to be added, it sounds like a bad water inlet valve, right?  No--I replaced that and get the exact same symptoms.

Since I had similar symptoms about 2 months ago, that ended up being a bad drain pump motor, I tested the motor resistance (OK) and that it was getting voltage (OK), and could see that it tries to pump a small amount of residual water in the drain line, so it is turning.  Don't think it's the drain pump.

I then tested the voltage going to both the hot and cold water inlet valve solenoids, and neither is getting voltage when they should be opened.  I unplugged and replugged the wiring harness into the control unit to ensure a good connection.  I notice that when starting a cycle, the drain pump is running continuously until the error code stops the cycle. The manual description of the pressure switch says "If an overfill condition is detected by the pressure switch, the CCU will turn on the drain pump and attempt to stop filling."  So, could the pressure switch be falsely detecting an overfill, and therefore running both the drain pump and stopping water from coming in? I had dismissed the pressure switch because that is only noted as a possible problem for code FH if there is water in the unit, but it is not adding any water.

Could the pressure switch fail like this--falsely detecting an overfill rather than just not detecting any water?

Any other thoughts?

Oops, my correct model number is GHW9150PWO.

Could be a clog in the sensing tubing to the water level switch; pull it off and blow in it to check.

Yes, I've blown through the tube and it seems clear.  I've also tried it with the tube disconnected.  No water flow at all...

Blow in the water level switch, it should click off, maybe it is stuck.


[0] Message Index

[#] Next page

Go to full version