Forum Index > Range, Oven & Cooktop Repair

Whirlpool Oven Not Heating Properly

(1/3) > >>


My Whirlpool Super Capacity 465 (RF380LXKQ) electric range is not heating properly.  I used a digital meat thermometer suspended below the middle rack to check temperature. This way I could have the display outside while the door was closed.

When set to a temperature the preheat indicator comes on and the oven counts down the time till ready.  However when the time hits zero it is not at the proper temperature.  If I set it for 400F it will only be 300F when the time ends.  If I raise temperature to 415F it will eventually settle out around 400F.

I tried using the Oven Temperature Control adjustment in the manual but the amount that it is off by changes with temperature.  In order to get it to settle around 450F I had to have the oven set to 470F.

Any suggestion on what the problem is / how to troubleshoot it?  I really don't want to buy a new oven.

I would simply check the oven temperature probe against the RTD chart for the unit at trouble temperatures. The connection could also be coming loose causing a false reading. The stove appears very simple. Only the main E.O.C. and temperature probe control that circuit. Good Luck! :D

Thanks.  How do I do that?  I don't have any sort of manual for this oven.  So I don't know where the probe is or what exactly I am supposed to be checking.  I am new at playing with ovens. I am sure I have all the required tools either at home or work

Your model oven uses temp probe part # W10181986

Temp Probe Help Video

RTD Chart

Tech sheet for your model attached.

Thanks.  I was also able to search the web and find a service manual for it.

Hopefully I am all set.  I wil report back if it worked or not.


[0] Message Index

[#] Next page

Go to full version