Forum Index > Dryer Repair

Whirlpool Dryer no Heat


I am working on a Whirlpool Elite Dryer model# 110.64982300 and when it first came in they said it would not heat and I checked all the thermastats and such and the wire harness to the motor was not plugged in all the way, I plugged it in and they said it worked fine for one load... I tried it and it heated for a while and then when cool... Is this a thermastat problem or something else? I thought a thermasta either works or does't work?? Also ther is a little board in their which shows no signs of any burn marks... Thanks fro Any Help and suggestions you have....and a belated Merry Christmas


* [size=78%]line voltage  ,[/size][size=78%][/color]heater relay, high limit,heater,[/size]centrifugal switch,thermistor or electronic board.Make sure you have proper voltage under a load on dryer by pig tail to rural out power supply. hot legs to neutral   with dryer is running.You should have 48 VDC at heater relay in control panel.Possilbe bad thermistor maybe put one in and see what you get.

Must of hit something wrong why i was typing.


[0] Message Index

Go to full version