Forum Index > Dryer Repair

Neptune mde5500ayw Dryer will not start


Hi Guys I'm new here, being an electronics tech i've fixeed all my appliances before with no help but this beast has me stumped.  when power is applied it comes up in normal, sensor dry, high heat and start flashing.  push start nothing happens. verified thermistor, thermal fuses, thermal switches motor, and heating element per service manual.  ohmed out all connections to control panel and switches  worked fine, so per service manual and bunches of other threads advice i purchaqsed a control board put it in applied power it worked for one dry cycle then went back to this crap,  per the service manual i should be able to enter service mode with "damp dry&time -"  but that seems to do nothing.  I've also cleaned the sensor bars and installed all new duct from it  to outsidesometimes if you unplug it for several hours  it may come up and let you get on cycle out of it.  I hope someone has a good answer, we bought this P.O.S. from a used appliance place and they will not even return my calls.  oh did i mention that several times it has came out of sleep and beep/chirp incessantly?  any help would be tremendously appreciated

richard dicarlo:
did you ever solve this? it sounds similar to a problem i am  having with a mde3000


[0] Message Index

Go to full version