ApplianceJunk.com

Forum Index => Range, Oven & Cooktop Repair => Topic started by: Cananot on January 21, 2014, 12:45:11 PM

Title: Jen air jes9750bad
Post by: Cananot on January 21, 2014, 12:45:11 PM
Ok working on this Jen air jes9750bas (http://appliancejunk.com/forums/index.php?action=search2;search=jes9750) first time I go there and it don't even get to 350 so changed out the sensor that helped a little replaced oven control board and that solved now they call me back and tell me it goes to the temp but don't stay there unless you open the door to let heat out and then the element kicks back on so I go there and it gets up to temp and i waited and sure enough it won't hold the temp less you open the door its not cycling ??? ? Do I have a bad board ??? Any thoughts ..
Title: Re: Jen air jes9750bad
Post by: MajorApp on January 21, 2014, 07:20:46 PM
I've had similar issues with JennAir ranges that turned out to be a faulty door latch assembly.
Title: Re: Jen air jes9750bad
Post by: Cananot on January 21, 2014, 07:31:18 PM
 So your saying its the door latch ? That's why its not cycling yes i know power runs thru the latch and i didn't even see if the door locked but i guess i could check into that when i go back there got a manual on it so gonna go thru some test i check into that since unit hasn't thrown any error codes 
Title: Re: Jen air jes9750bad
Post by: MajorApp on January 21, 2014, 10:42:46 PM
I'm not saying for sure it's the door latch but quite possible. The issues I had were on the JennAir gas range version. I also replaced the control board and the oven sensor before I discovered the door latch was the problem. On one of the ovens I had to replace the latch twice in one year. Being an intermittent problem it was observation and dumb luck that I figured it out.
Title: Re: Jen air jes9750bad
Post by: AJ on March 09, 2014, 02:33:39 PM
Cananot, got any updates for us?
Did you get it fixed?