Author Topic: GE REF mod PSC23SGMBBS  (Read 876 times)

Offline All Brand

  • Technician
  • Member Since: Sep 2010
  • Posts: 70
  • Country: us
GE REF mod PSC23SGMBBS
« on: January 13, 2012, 08:20:20 AM »
Need to replace temp control board. old board is a 4 plug connector,new board has 2.Factory says this is the new replacement p# wr55x10092 chgs to a p# wr55x10120. No directions in box , were do the other 2 plug commectors go .GE is NO Help,they claim there techs would know what to do any ideas thanks Dave all brand appliance repair

Model PSC23SGMBBS



Offline theoldstoveguy

  • Technician
  • Member Since: Jan 2008
  • Posts: 1318
  • Country: us
    • Buy me a beer through paypal
Re: GE REF mod PSC23SGMBBS
« Reply #1 on: January 13, 2012, 01:27:26 PM »
On the model list it has a sheet of paper stating something about only using J3. It is on the link under that model number ,click on control and it shows it.http://www.appliancepartspros.com/Appliance-Parts/ge-board-assembly-te-item-number-ap3160651.aspx

Offline tgoods

  • Technician
    Moderator
  • Member Since: Jul 2010
  • Posts: 1509
  • Country: us
    • Buy me a beer through paypal
Re: GE REF mod PSC23SGMBBS
« Reply #2 on: January 13, 2012, 03:28:23 PM »

Offline All Brand

  • Technician
  • Member Since: Sep 2010
  • Posts: 70
  • Country: us
Re: GE REF mod PSC23SGMBBS
« Reply #3 on: January 22, 2012, 10:41:55 AM »
Thanks problem solved

Offline All Brand

  • Technician
  • Member Since: Sep 2010
  • Posts: 70
  • Country: us
Re: GE REF mod PSC23SGMBBS
« Reply #4 on: January 26, 2012, 06:45:36 AM »
i replace the board know getting 555 on both displays. if i hit temp up or down i get all 444 or 333 etc. the directions say use j3 plug on new board,but the plug connector is different . is there a harness to purchase or what am i doing wrong thanks dave