Author Topic: F32 & F33 Codes, Whirlpool Cabrio  (Read 6783 times)

Offline xzqzq

  • VIP Member
  • Member Since: Nov 2011
  • Posts: 3
F32 & F33 Codes, Whirlpool Cabrio
« on: November 04, 2011, 04:00:48 AM »
My Whirlpool Cabrio, Type 580,  wtw6400sw3, cy0270534  is faulting during rinse exhaust, showing ' Ld '.      Diagnostic shows ' F 32 '  &  ' F 33 '.   I took the hose off, made sure it was clear, same with drainpipe.  Anyone know what the problem is ?   Thanks  !!

Offline schaffersapplian

  • Technician
  • Member Since: Oct 2008
  • Posts: 619
  • Country: us
  • Every action has a reaction
    • Facebook
Re: F32 & F33 Codes, Whirlpool Cabrio
« Reply #1 on: November 04, 2011, 07:21:42 AM »
A F32 code indicates a Long drain as well as LD.  If you have checked the discharge hose to make sure of no blockages, Next i would look at the pump itself.  I have seen change gather in the pump and create enough of a blockage to keep the water from going out in a timely manner.   Lastly  Does the water go out in a timely manner?  If you are still getting a code, and you know that the pump is good, the impeller blades on the pump are intact, the water is leaving the tub fast.  The last and only thing left would be the control which monitors the amount of water in the tub.  Very  unlikely this is the culprit, but its a possibility.  Good luck.
Authorized Samsung, Electrolux, Whirlpool, GE, Fisher Paykal, and Maytag Servicer with over 10 years experience.

Offline xzqzq

  • VIP Member
  • Member Since: Nov 2011
  • Posts: 3
Re: F32 & F33 Codes, Whirlpool Cabrio
« Reply #2 on: November 04, 2011, 06:54:04 PM »
Thanks for the help !!  The problem only occurs during the rinse exhaust, @ 13 minutes before the end of the cycle.   The water pumps out just fine, after the wash segment.   

Offline xzqzq

  • VIP Member
  • Member Since: Nov 2011
  • Posts: 3
Re: F32 & F33 Codes, Whirlpool Cabrio
« Reply #3 on: November 05, 2011, 05:28:19 AM »
I took the pump apart - seemed OK.   Then I took the control panel off, to get to the electronics, and disconnected and reconnected every electrical lead to the electronic components.     After reassembling the washer, it worked just fine.  It appears to have been a bad electrical connection. 

Offline schaffersapplian

  • Technician
  • Member Since: Oct 2008
  • Posts: 619
  • Country: us
  • Every action has a reaction
    • Facebook
Re: F32 & F33 Codes, Whirlpool Cabrio
« Reply #4 on: November 05, 2011, 07:58:03 AM »
Excellent!  You have a pretty easy machine to work on.  And for the most part, pretty reliable.  Some of the replacement parts are expensive,  but all in all, a pretty well built unit.   From what you have found,  If the problem continues, I would assume the control would be the culprit.  I have seen a poor electrical connection at the control which was causing "ghost codes" before.  I typically will use a very small amount of contact cleaner, and some Electrical grease to remedy the problem.  Good Luck! O0
Authorized Samsung, Electrolux, Whirlpool, GE, Fisher Paykal, and Maytag Servicer with over 10 years experience.

 

Whirlpool Cabrio - ERROR CODES ??

Started by Blaiser

Replies: 2
Views: 820
Last post November 21, 2013, 06:51:01 AM
by Blaiser
Whirlpool Cabrio

Started by Digger

Replies: 5
Views: 7230
Last post September 13, 2008, 09:26:23 AM
by AJ
Whirlpool Cabrio Washer F51 Error

Started by TechnicianBrian

Replies: 5
Views: 17993
Last post September 09, 2014, 06:57:41 PM
by Lee28
Whirlpool Duet Washer Error Codes

Started by AJ

Replies: 0
Views: 28160
Last post September 13, 2008, 10:38:25 PM
by AJ
WHIRLPOOL DUET WASHER ERROR CODES

Started by IPSONDN1

Replies: 3
Views: 9488
Last post December 12, 2008, 12:48:37 PM
by IPSONDN1
Whirlpool Cabrio sounds like a jet engine in spin

Started by Anawim

Replies: 4
Views: 6933
Last post December 31, 2008, 07:11:56 AM
by AJ