Author Topic: GW395LEGB5 Whirlpool Gas Oven Not Heating  (Read 1295 times)

Offline AJ

  • Technician
    Administrator
  • Member Since: Jun 2007
  • Posts: 9330
  • Country: us
    • ApplianceJunk.com - Appliance Repair
GW395LEGB5 Whirlpool Gas Oven Not Heating
« on: September 25, 2011, 08:49:01 AM »
Model: GW395LEGB5

Customer said everything works with the stove expect the oven.

I did a quick check and found that the top burners worked and so did the broil burner.

When I turned on the oven I could not see the normal glow from the bake ignitor coming on. I checked for power to the ignitor with my non-conductive voltage tester. There was voltage to the ignitor so I replace the bake ignitor, part # 9782065

After replacing the bake ignitor with a new one the oven worked great.

Hope you find our site helpful.
Follow us on Google+

donate
$1, $2, $5, $10, $20, $50
 

Whirlpool Oven Not Heating Properly

Started by Crash55

Replies: 10
Views: 1548
Last post January 31, 2013, 05:07:47 PM
by Crash55
Whirlpool Buit-In Oven - No heat

Started by AJ

Replies: 0
Views: 2328
Last post December 28, 2007, 07:41:25 AM
by AJ
Whirlpool Range Not Heating

Started by TechnicianBrian

Replies: 0
Views: 1966
Last post March 26, 2008, 12:26:47 PM
by TechnicianBrian
Whirlpool Range Bake Element Not Heating

Started by TechnicianBrian

Replies: 0
Views: 1893
Last post April 08, 2008, 07:08:16 AM
by TechnicianBrian
Whirlpool Range No Oven Operation

Started by TechnicianBrian

Replies: 5
Views: 3074
Last post April 24, 2008, 01:32:13 PM
by JWWebster
Whirlpool Oven E1 F2 Error

Started by TechnicianBrian

Replies: 0
Views: 13029
Last post July 11, 2008, 07:59:01 AM
by TechnicianBrian