Author Topic: Whirlpool Range Not Heating  (Read 1511 times)

Offline TechnicianBrian

  • Technician
  • Member Since: Dec 2007
  • Posts: 390
  • Country: us
    • TechnicianBrian.com
Whirlpool Range Not Heating
« on: March 26, 2008, 12:26:47 PM »
Model # RDE3020W, this unit would not heat using the bake cycle, but would work fine when broil was selected. Took a quick look at the bake element and the problem presented itself (see photo) complete with the tell tale burn marks on the liner. Replaced the bake element with a new one and this range now heats fine.



Whirlpool Oven Bake Element Part # 865940
« Last Edit: March 26, 2008, 12:31:18 PM by AJ »

 

Whirlpool Range Bake Element Not Heating

Started by TechnicianBrian

Replies: 0
Views: 1235
Last post April 08, 2008, 07:08:16 AM
by TechnicianBrian
Removing main top on whirlpool gas range with sealed burners

Started by Vornato

Replies: 1
Views: 6861
Last post December 06, 2007, 07:17:47 AM
by apptech
Whirlpool Range - Top Burner Not Working

Started by AJ

Replies: 0
Views: 2549
Last post December 28, 2007, 12:21:08 AM
by AJ
Whirlpool Electric Range - Bake Cycle Not Working

Started by AJ

Replies: 0
Views: 2116
Last post January 01, 2008, 03:44:30 PM
by AJ
8178194 Whirlpool Polar Range Service Repair Manual

Started by AJ

Replies: 0
Views: 1721
Last post March 24, 2008, 07:46:50 AM
by AJ
Whirlpool Range No Oven Operation

Started by TechnicianBrian

Replies: 5
Views: 1947
Last post April 24, 2008, 01:32:13 PM
by JWWebster