Free Service - Appliance Repair Help & Troubleshooting

Author Topic: Kenmore Washer Agitates & Spins but does not Fill  (Read 5107 times)

Offline bennettee

  • VIP Member
  • Member Since: Jun 2010
  • Posts: 4
Kenmore Washer Agitates & Spins but does not Fill
« on: June 02, 2010, 12:29:54 PM »
As soon as I start the machine, it starts agitating without filling with water. The timer moves through the cycles fine and it spins fine, it just never fills with water. I tested the water level switch for continuity and when I blow into the hose, I hear the switch click and the connected contacts change accordingly. I also checked the fill valve coils for continuity.

I'd appreciate any help on what to check next.

Thank you,
Paul

Model 110.20892990

Offline kellonnie

  • Technician
  • Member Since: Oct 2009
  • Posts: 284
Re: Kenmore Washer Agitates & Spins but does not Fill
« Reply #1 on: June 02, 2010, 01:31:48 PM »
make sure hose isnt pinched.

Offline bennettee

  • VIP Member
  • Member Since: Jun 2010
  • Posts: 4
Re: Kenmore Washer Agitates & Spins but does not Fill
« Reply #2 on: June 02, 2010, 01:47:59 PM »
Hoses aren't pinched. I'm going to take them off and check them and the screens, though.

One more piece of info that may or may not be relevant: over the last week or so, I've heard a knocking sound most times water was running in the house. I never tracked it, but it seemed to be coming from the general vicinity of the washing machine and it disappeared roughly around the same time the washing machine broke. Related?

Offline kellonnie

  • Technician
  • Member Since: Oct 2009
  • Posts: 284
Re: Kenmore Washer Agitates & Spins but does not Fill
« Reply #3 on: June 02, 2010, 01:54:51 PM »
i was talking about the clear hose that conects to the water level switch, this tells the washer it has enough water to agitate, seeen the get pinched and eithor the waher over flows or doesnt fill.

Offline bennettee

  • VIP Member
  • Member Since: Jun 2010
  • Posts: 4
Re: Kenmore Washer Agitates & Spins but does not Fill
« Reply #4 on: June 02, 2010, 02:08:37 PM »
Sorry about that. That hose doesn't appear to be pinched and I can't see any cracks or holes in it. And when I blow in it, the switch activates.

Thanks for the help.

Offline kellonnie

  • Technician
  • Member Since: Oct 2009
  • Posts: 284
Re: Kenmore Washer Agitates & Spins but does not Fill
« Reply #5 on: June 02, 2010, 02:41:04 PM »
do you have water flo? from the wall

Offline bennettee

  • VIP Member
  • Member Since: Jun 2010
  • Posts: 4
Re: Kenmore Washer Agitates & Spins but does not Fill
« Reply #6 on: June 02, 2010, 02:45:35 PM »
Yup...water flow is good.

What I don't get is if the agitator is running, that means the machine thinks the water level is good, right? So, what else besides the water level switch could cause that?

Offline kellonnie

  • Technician
  • Member Since: Oct 2009
  • Posts: 284
Re: Kenmore Washer Agitates & Spins but does not Fill
« Reply #7 on: June 02, 2010, 05:07:47 PM »
have you checked the timer?

Offline drummachine24

  • VIP Member
  • Member Since: Jun 2016
  • Posts: 1
Re: Kenmore Washer Agitates & Spins but does not Fill
« Reply #8 on: June 04, 2016, 03:27:30 PM »
I know this post is pretty old, but I thought I'd post my answer in case someone runs across it like I did.

This issue was definitely caused by the water level pressure switch.  Here is what I did to fix it.

First, I checked to water tube attached to it to make sure it wasn't plugged and wasn't full of water.  It was fine and I could easily blow through the tube, so it was fine.

I then took the switch out - Watch this video for how to do that. ( ).

Once I had the switch out, I decided to see if it could be repaired, instead of having to buy a new one - So, I took it apart. 

The end where the hose plugs in is pretty much a cap, and all around the cap are clips that keep it in place. Popping each clip with a small flat head screw driver, I could then pop it off.  Underneath was a rubber diaphragm with a plastic center piece.  Remove the diaphragm and you'll see the inner workings of the switch.  It's a pretty simple switch.  In the center, you'll see a white plastic piece that connects to a metal arm, that opens or closes the circuit.  There are 3 latch tabs around the switch holding the guts of the switch into the housing.  Push out those 3 tabs and you can pull the inside of the switch out.  Once the switch is free from the housing, you'll see a column with an end plastic end piece on it.  If can pop off that end piece and you will see 2 springs inside.  For me, those springs were old and just not providing enough tension to keep the circuit open, so I took out the springs and stretched them out some.  This provided more required tension to compress the springs, so that that diaphragm couldn't push down the center rod as easy.  Once I stretched out the springs a bit, I put the switch back together (Be careful to see how it goes together, as the plastic end cap and the center rod fit together a certain way.  Also, placing the end piece with the hose attachment back on with the diaphragm in place is a little tricky.)

I installed the switch back into the control faceplate, hooked up the wires and the water level tube, and tested.  I had a working washing machine again!!!  I know the above SEEMS like a lot, but the whole process took MAYBE 25 minutes.  If you're careful in disassembling and reassembling the switch get it working pretty quick, and free!

 

Sears Kenmore Washer 80 series not draining but agitates and spins OK

Started by mem1966

Replies: 4
Views: 8438
Last post February 06, 2009, 04:20:43 PM
by jumptrout51
Whirlpool Washer agitates and spins when it wants to!

Started by tidebatt1

Replies: 48
Views: 26292
Last post March 28, 2008, 02:21:52 PM
by JWWebster
Kenmore Washer will not drain or spin, agitates on the agitate lo cylce only

Started by mattz

Replies: 5
Views: 11894
Last post March 11, 2008, 09:21:43 AM
by mattz
Kenmore washer agitator spins when washer is in spin mode w/awful clunking sound

Started by snowell

Replies: 6
Views: 10214
Last post November 20, 2008, 02:30:13 AM
by snowell
Kenmore Series 90 washer won't fill

Started by iliiinieis

Replies: 15
Views: 14998
Last post January 06, 2009, 05:56:14 PM
by iliiinieis
Washer only agitates and spins in delicate mode

Started by tgbruner

Replies: 4
Views: 4978
Last post January 26, 2009, 11:09:36 PM
by tgbruner