Author Topic: GE Commercial Coin-Op Washer "No high speed final spin"  (Read 3507 times)

Offline Shanahan

  • VIP Member
  • Member Since: Jan 2010
  • Posts: 5
GE Commercial Coin-Op Washer "No high speed final spin"
« on: January 11, 2010, 10:34:15 PM »
I have four of these machines a year and a half old, and nothing but problems as of late. Figures... full warranty on machines ran out at one year and now the problems start, we pay labor, service calls, and diagnostic fees since. Replaced motors on two machines in the last month. This last replacement of the motor for the "no high speed final spin" Didn't solve my problem. Technician comes out gets the code, tells me I need a new motor, special order of course. Motor came today slapped it in and still "no high speed final spin." I've just about had it with this junk and GE! So I'm here for help! Machine fills, drains, agitates, spins slow, but no high speed final spin, just spins slowly through the whole final spin phase. Mode shifter coil? Please help before I load these suckers up and make my disgruntled run to GE corporate office to drop these pieces of shyt at their front door!! :-)

Thanks

Model WMCD2050H1WC

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: GE Commercial Coin-Op Washer "No high speed final spin"
« Reply #1 on: January 11, 2010, 11:44:46 PM »
All I can say is the old style GE topslosher was the very best laundry matt washer but these new models are shiite, always said that. The latest ones with the solenid shifter and the motor with the blinking lights is that what you have? Piece of crap too I bet.
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline Shanahan

  • VIP Member
  • Member Since: Jan 2010
  • Posts: 5
Re: GE Commercial Coin-Op Washer "No high speed final spin"
« Reply #2 on: January 12, 2010, 12:15:42 AM »
Yeah top loader, fully motor driven, no tranny. For the record my led blinks on and off with 1 sec intervals. Shows normal in stand by.

Offline Shanahan

  • VIP Member
  • Member Since: Jan 2010
  • Posts: 5
Re: GE Commercial Coin-Op Washer "No high speed final spin"
« Reply #3 on: January 29, 2010, 02:00:36 PM »
*UPDATE*

  Problem fixed! New timer installed, I now have my final high speed spin back. :-)

Offline Shanahan

  • VIP Member
  • Member Since: Jan 2010
  • Posts: 5
Re: GE Commercial Coin-Op Washer "No high speed final spin"
« Reply #4 on: January 30, 2010, 05:01:25 PM »
Did have...not anymore! WHAT THE HELL? The GE tech doesnt seem to know what the hell hes doin either! What are they doin guessin??


Offline jumptrout51

  • Technician
  • Member Since: Nov 2007
  • Posts: 1879
  • Country: us
    • Buy me a beer through paypal
Re: GE Commercial Coin-Op Washer "No high speed final spin"
« Reply #5 on: January 30, 2010, 06:43:46 PM »
From what you describe I would check every wire in the harness,especially those to the motor.
Take a Kid fishing.

Offline Shanahan

  • VIP Member
  • Member Since: Jan 2010
  • Posts: 5
Re: GE Commercial Coin-Op Washer "No high speed final spin"
« Reply #6 on: February 02, 2010, 03:47:35 PM »
GE back out again today, 3 hours they replaced the shaft and shifter coil. Still no workie!! JEEZUZ! Now they are tellin me its the selector switch. These assholes are guessin for sure! I told them I'm not payin shyt unless this suckers runnin right. Wanna now charge me 248.00 to put in a selector switch. Selector switch is 30-40 bucks and about 15min. What a bunch of crap man! 1 year warranty bumper to bumper, 5 years parts. After a year and a half, 3 machines have problems, and this one in particular... what a hunk of shit! GE NEVER NEVER AGAIN!

I'll check wire harness, and buy this switch.....will post results.

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: GE Commercial Coin-Op Washer "No high speed final spin"
« Reply #7 on: February 02, 2010, 04:44:22 PM »
Have you tried this: If the LED is flashing an error code, first thing to try is resetting the inverter board:

To Reset the Inverter Board: Push the timer knob in so the washer is idle. Unplug the machine for one minute. Plug back in and raise and lower the lid six times within 12 seconds.

After resetting the inverter board, put the machine in a spin cycle and see if it runs. If not, check for a green blinking light on the inverter board.  If no light you probably have a blown fuse built into the neutral side of the harness on the white/red wire.
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

 

Maytag washer noise during high speed spin

Started by madbchron

Replies: 2
Views: 3048
Last post February 05, 2008, 10:03:59 AM
by JWWebster
washer spins but no high speed spin

Started by Big Arn

Replies: 4
Views: 4677
Last post September 13, 2008, 12:49:01 PM
by Big Arn
Kenmore 41744052401 washer - No high speed spin.

Started by ALTANertive

Replies: 2
Views: 3415
Last post February 02, 2009, 09:17:47 PM
by ALTANertive
Washer does not enter high speed spin!

Started by mdsarazin

Replies: 11
Views: 7063
Last post February 19, 2009, 11:46:18 PM
by mdsarazin
GE washer stuck in spin cycle on "regular", OK in perm press..?

Started by Black88GTA

Replies: 11
Views: 4315
Last post September 02, 2009, 02:43:14 PM
by Repair-man
Maytag washer transmission pulley locks up and won"t spin

Started by mattlwoo

Replies: 6
Views: 7318
Last post September 10, 2009, 02:38:06 PM
by mattlwoo