Author Topic: Kenmore elctric stove- bad connection where element plugs in  (Read 1335 times)

Offline tcape

  • VIP Member
  • Member Since: Jun 2009
  • Posts: 71
Kenmore elctric stove- bad connection where element plugs in
« on: February 03, 2010, 06:25:02 PM »
Is there a specific part number for the connector for this?

I found a terminal block clip part, but not sure that is it.
Part for KENMORE, Model # 9119349180

Number:
    WB17X211

and the

Terminal block

Part for KENMORE, Model # 9119349180

Number:
    WB17X210

The stove I'm working on  has an intermittent problem the burner element where it plugs into the receptacle. sometimes it gets hot, sometimes not, depending on how you plug it in or wiggle it around. I have 220 there when I plugged my voltmeter, so I believe the problem is a loose connection where the element ringtabs slide into the receptacle.

Am I missing something?


Thanks


Tony

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

donate
$1, $2, $5, $10, $20, $50
 

Old Kenmore Electric Stove- Element Disc out-Infinite switch?

Started by tcape

Replies: 16
Views: 5598
Last post October 30, 2010, 01:28:07 PM
by tcape
Kenmore stove

Started by Jim Radford

Replies: 25
Views: 6697
Last post January 28, 2010, 08:04:21 PM
by viking351
Kenmore Stove Shuts Off

Started by blondejon

Replies: 2
Views: 929
Last post February 07, 2012, 10:32:46 PM
by blondejon
Kenmore Stove

Started by Shadetree504

Replies: 14
Views: 2033
Last post August 31, 2012, 11:13:13 AM
by AJ
kenmore plus smooth top stove

Started by stormylove2

Replies: 2
Views: 466
Last post August 26, 2013, 09:23:32 PM
by krazytech
Kenmore Elite cooktop Control board connection help

Started by aak20in

Replies: 7
Views: 778
Last post March 24, 2014, 04:23:48 PM
by AppTek