Author Topic: Kitchenaid oven controls operate but no heat  (Read 4493 times)

Offline mtnbikeman

  • VIP Member
  • Member Since: Nov 2009
  • Posts: 5
Kitchenaid oven controls operate but no heat
« on: November 22, 2009, 01:57:25 PM »
Electric Convection oven no heat

The last time it ran, it was set to 350, heated to 210 degrees and then cooled to Lo. Now it never heats up. Of course I have tried all the various settings: bake (with and without convection), broil, even self clean. The other 220v appliances in the house are working.

The stovetop works and the oven controls seem to be fine. I tried using the temperature probe but that didnt get the heat to come on either.

Any ideas?

I have the parts manual from the kitchenaid web site for reference.

Model KESH307GWH1

Offline jumptrout51

  • Technician
  • Member Since: Nov 2007
  • Posts: 1879
  • Country: us
    • Buy me a beer through paypal
Re: Kitchenaid oven controls operate but no heat
« Reply #1 on: November 22, 2009, 04:33:01 PM »
Disconnect power to the range. Remove the bake element and test it with a volt/ohm meter set for ohms. No reading is a bad element.
If the element is good you will have a bad ERC(clock).
Take a Kid fishing.

Offline mtnbikeman

  • VIP Member
  • Member Since: Nov 2009
  • Posts: 5
Re: Kitchenaid oven controls operate but no heat
« Reply #2 on: November 22, 2009, 07:52:05 PM »
Since neither element would turn on, I tested both. Both had continuity but is there a ohm measurement I should expect?

Assuming theses are ok, you are suggesting a $300 clock replacement. Is there anything else I could test first? What if I replace the clock and it still wont work?

Any suggestions?

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8781
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Kitchenaid oven controls operate but no heat
« Reply #3 on: November 22, 2009, 09:56:20 PM »
An element is gonna be good or bad no in between. Check with bruce:

Fixyourboard.com
« Last Edit: November 22, 2009, 09:57:54 PM by JWWebster »
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline mtnbikeman

  • VIP Member
  • Member Since: Nov 2009
  • Posts: 5
Re: Kitchenaid oven controls operate but no heat
« Reply #4 on: November 22, 2009, 11:20:23 PM »
I opened up the control area and removed the "ERC". There were 4 clear plastic housings for pre-relays? for each element circuit. 3 of the 4 had been blackened. I popped off the clear covers and sanded the contacts. Put it all back together... no luck. Oh well, I guess I found the evidence I needed before buying a replacement. I hope getting a new one fixes the problem!

Could something else be bad and caused this to happen? or is it just normal "wear and tear"?

Offline Repair-man

  • Technician
  • Member Since: Feb 2008
  • Posts: 3020
  • Country: us
  • The Virtual Repairman
    • The Virtual Repairmans Appliance Help
Re: Kitchenaid oven controls operate but no heat
« Reply #5 on: November 23, 2009, 07:18:56 AM »
I believe this oven has a hi-limit disc mounted on the back or the top of the oven cavity. If you recently self cleaned or the oven got way out of temp range, this hi limit fuse will open. You can view the blowup of your model on the diagram lookup on the left side of this page with your model number.

See Pic
« Last Edit: November 23, 2009, 07:24:02 AM by Repair-man »
"It's only expensive if someone else fixes it for you" -
The Virtual Repairman   www.repair2000.com

Offline mtnbikeman

  • VIP Member
  • Member Since: Nov 2009
  • Posts: 5
Re: Kitchenaid oven controls operate but no heat
« Reply #6 on: November 24, 2009, 02:19:26 PM »
Ok my worst fear has come true... I spent the $$$ to replace the ERC (clock/control unit). Controls function as with the old ERC but still NO HEAT. Oven temp stays a "Lo" and is cold.

What else can I suspect? There is part 9751948, Relay, Dlb. I tested and the coil leads have continuity with some resistance...

Im not sure what to do next.

Offline Repair-man

  • Technician
  • Member Since: Feb 2008
  • Posts: 3020
  • Country: us
  • The Virtual Repairman
    • The Virtual Repairmans Appliance Help
Re: Kitchenaid oven controls operate but no heat
« Reply #7 on: November 24, 2009, 02:57:34 PM »
Uh, did you check the post I made just above regarding the hi limit thermodisc? The oven cannot heat if it is open. The control may say it is heating but no poweer can get to the elements unless this fuse is good.
"It's only expensive if someone else fixes it for you" -
The Virtual Repairman   www.repair2000.com

Offline mtnbikeman

  • VIP Member
  • Member Since: Nov 2009
  • Posts: 5
Re: Kitchenaid oven controls operate but no heat
« Reply #8 on: November 24, 2009, 04:09:47 PM »
On my oven, this is part 341196 Thermo-Disc. I tested it and it has continuity.

There must be more parts to test because it is still not working.

Offline Repair-man

  • Technician
  • Member Since: Feb 2008
  • Posts: 3020
  • Country: us
  • The Virtual Repairman
    • The Virtual Repairmans Appliance Help
Re: Kitchenaid oven controls operate but no heat
« Reply #9 on: November 24, 2009, 04:15:04 PM »
Well, unless you have calibrated eyeballs, better whip out your voltmeter and confirm  240 volts at the red and black power wires  to the oven. Without the full voltage, the display may work, but no heat. The fact that other appliances work does not impact this circuit. It must be verified.

You have the parts list, do you need the wiring diagram to check it out? Circuits may have to be traced.

Here's the Tech Sheet

Sure sounds like voltage issues to me.
« Last Edit: November 24, 2009, 04:19:06 PM by Repair-man »
"It's only expensive if someone else fixes it for you" -
The Virtual Repairman   www.repair2000.com

 

Kitchenaid KEBC107 Oven No Heat

Started by thepicker

Replies: 5
Views: 8246
Last post January 16, 2008, 04:00:06 PM
by RegUS_PatOff
Kitchenaid Double Oven no Heat after Self Clean

Started by TechnicianBrian

Replies: 0
Views: 5404
Last post November 18, 2008, 02:03:23 PM
by TechnicianBrian
Kitchenaid Double Oven won't heat

Started by emshields

Replies: 4
Views: 3012
Last post November 07, 2011, 08:57:09 PM
by tgoods
Whirlpool Buit-In Oven - No heat

Started by AJ

Replies: 0
Views: 2826
Last post December 28, 2007, 07:41:25 AM
by AJ
Kitchenaid Range no Oven Lights

Started by TechnicianBrian

Replies: 0
Views: 3265
Last post May 20, 2008, 10:03:36 PM
by TechnicianBrian
Kitchenaid Oven not Heating after Self Cleaning

Started by TechnicianBrian

Replies: 0
Views: 3792
Last post August 27, 2008, 06:46:01 AM
by TechnicianBrian