Author Topic: vgic3054bss Viking Range - only 3 months old  (Read 16760 times)

Offline chilicasa@hotmai

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 26
vgic3054bss Viking Range - only 3 months old
« on: September 04, 2009, 11:40:15 AM »
Hey Experts
We have a Viking 4 burner gas range up at the cabin.
Works fine except...
Each burner has its own ignitor and they all ignite independently.
Problem is the left front one ignites them all for some reason and then keeps trying to ignite them all even after the left front has lit.
We are very remote so to get a reapair person that knows anything about viking would cost me 7 hours travel time each way. 14 X $80... you get the drift.
Any idea what might be wrong?
Thanks

TR

Offline Repair-man

  • Technician
  • Member Since: Feb 2008
  • Posts: 3020
  • Country: us
  • The Virtual Repairman
    • The Virtual Repairmans Appliance Help
Re: Viking Range - only 3 months old
« Reply #1 on: September 04, 2009, 01:23:14 PM »
The ingitor on this model is a re-inigtion type of module. It actually uses a path to ground thru the very flame itself to stop the burner from clicking. I believe that all 4 burners will show a spark even if you are only lighting one. Normal. The clicking means that one of the burner caps is not seated correctly to allow the spark electrode to go to ground as it should. Check that the burner caps are properly in place and not jammed on there in the wrong position.
"It's only expensive if someone else fixes it for you" -
The Virtual Repairman   www.repair2000.com

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Viking Range - only 3 months old
« Reply #2 on: September 04, 2009, 03:30:27 PM »
13. Continued reignition on top 13A. Defective spark switch or 13A. Replace switch.
burner. incorrect switch.
13B. Position of spark electrode 13B. Align spark electrode with burner
port.
13C. Lack of or improper ground. 13C. Check ground outlet. Check ground at the module.
13D. Defective spark module. 13D. Replace spark module
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Viking Range - only 3 months old
« Reply #3 on: September 04, 2009, 03:33:32 PM »
Each top burner valve has a switch mounted on it. Remove 1 wire from each switch till you find the defective switch. With all switches in off position find the switch with continuous continuity.
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline RegUS_PatOff

  • Technician
  • Member Since: Dec 2007
  • Posts: 1410
  • Country: us
Re: Viking Range - only 3 months old
« Reply #4 on: September 05, 2009, 03:29:58 AM »
13C. Lack of or improper ground.
13C. Check ground outlet.
Check ground at the module.
YES, the Wall Outlet must be wired with the correct polarity
(L1 & Neutral) and have a valid ground.
« Last Edit: September 05, 2009, 03:32:13 AM by RegUS_PatOff »
After leaving this Earth, "Do you want the smoking or non-smoking section?"

Offline chilicasa@hotmai

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 26
Re: Viking Range - only 3 months old
« Reply #5 on: September 05, 2009, 09:53:17 AM »
Repair-Man
All the caps are seated OK
They just sit on... nothing special
Will move on to the next suggestion.

Offline chilicasa@hotmai

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 26
Re: Viking Range - only 3 months old
« Reply #6 on: September 05, 2009, 09:56:07 AM »
13C. Lack of or improper ground.
13C. Check ground outlet.
Check ground at the module.
YES, the Wall Outlet must be wired with the correct polarity
(L1 & Neutral) and have a valid ground.
Wall outlet is wired correctly
Stove just started doing this after a few months.
Only tries to ignite ALL burners when you use the front left
hmm...

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Viking Range - only 3 months old
« Reply #7 on: September 05, 2009, 10:25:52 AM »
Did you have a boil over? Sometimes the liquid will go into a switch and cause this problem. After a few days it will dry out in some cases.
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline Repair-man

  • Technician
  • Member Since: Feb 2008
  • Posts: 3020
  • Country: us
  • The Virtual Repairman
    • The Virtual Repairmans Appliance Help
Re: Viking Range - only 3 months old
« Reply #8 on: September 05, 2009, 12:47:54 PM »
Quote
Only tries to ignite ALL burners when you use the front left
hmm...

Now it becomes apparent this is a module issue. Also, check to see that the ceramic insulator on the left burner electrode is not hairline-cracked.
"It's only expensive if someone else fixes it for you" -
The Virtual Repairman   www.repair2000.com

Offline chilicasa@hotmai

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 26
Re: Viking Range - only 3 months old
« Reply #9 on: September 05, 2009, 02:33:47 PM »
Did you have a boil over? Sometimes the liquid will go into a switch and cause this problem. After a few days it will dry out in some cases.
Not sure what a boil is but the ignitor is protected by the top cover plate.
Its been doing it for about three weeks. So it is dry... wife doesnt cook much...
Read next comment

Offline chilicasa@hotmai

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 26
Re: Viking Range - only 3 months old
« Reply #10 on: September 05, 2009, 02:35:11 PM »
Quote
Only tries to ignite ALL burners when you use the front left
hmm...

Now it becomes apparent this is a module issue. Also, check to see that the ceramic insulator on the left burner electrode is not hairline-cracked.
I will and report back

Offline chilicasa@hotmai

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 26
Re: Viking Range - only 3 months old
« Reply #11 on: September 05, 2009, 02:54:54 PM »
SO... TODAY
I will report this in deatail
Left Back... turn the dial - it sparks and lights
Left Front... turn the dial - it sparks and lights but also makes the Left Back sparks cont..
Right Back... turn the dial - no spark - no light - but Left Back sparks continuously
Right Front... turn the dial - no spark - no light - but Left Back sparks continuously
hmmmm........

Offline Repair-man

  • Technician
  • Member Since: Feb 2008
  • Posts: 3020
  • Country: us
  • The Virtual Repairman
    • The Virtual Repairmans Appliance Help
Re: Viking Range - only 3 months old
« Reply #12 on: September 05, 2009, 04:50:43 PM »
Go buy yourself a spark module so you'll quit hm-m-ming :)
"It's only expensive if someone else fixes it for you" -
The Virtual Repairman   www.repair2000.com

Offline chilicasa@hotmai

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 26
Re: Viking Range - only 3 months old
« Reply #13 on: September 05, 2009, 07:17:16 PM »
Go buy yourself a spark module so you'll quit hm-m-ming :)
so ya think thats what it is?
I will look into purchasing a module.
Is there just 1 for the stove or does each burner have one?
Is there any other test or info you all require to make the call?

Offline chilicasa@hotmai

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 26
Re: Viking Range - only 3 months old
« Reply #14 on: September 05, 2009, 07:32:24 PM »
Is it normal that the ignitors keep clicking when the burners are lit?
OR
should they shut off when they are lit?
ALSO
is it normal that when you turn on one burner that they all start the ignitors?

donate
$1, $2, $5, $10, $20, $50
 

Viking Dual Fuel Range

Started by TechnicianBrian

Replies: 0
Views: 1868
Last post April 04, 2008, 05:00:21 PM
by TechnicianBrian
Dual Fuel 30 inch Range from Viking

Started by TechnicianBrian

Replies: 1
Views: 3232
Last post July 16, 2008, 08:32:43 PM
by JWWebster
RS2466CW1 Display on viking range

Started by 66carlos66

Replies: 3
Views: 2533
Last post August 20, 2008, 06:30:22 AM
by Repair-man
VDSC36746SS 5 year old Viking Range Ignitor problem

Started by Dug

Replies: 12
Views: 12994
Last post November 19, 2009, 11:33:33 PM
by krazytech
vgic306 Viking Range fun

Started by bakeray

Replies: 1
Views: 1306
Last post March 19, 2010, 10:06:22 AM
by JWWebster
Viking gas range manual

Started by repair_quebec

Replies: 3
Views: 1776
Last post October 28, 2010, 04:14:11 PM
by repair_quebec