Author Topic: Beko Fridgefreezer  (Read 1542 times)

Offline chemically

  • VIP Member
  • Member Since: Jan 2009
  • Posts: 2
Beko Fridgefreezer
« on: June 16, 2009, 01:52:51 AM »
I have a problem with my fridgefreezer. The freezer part seems ok but there's a patch of ice/frost that keeps forming on the back of the fridge part.

Any help/advice on a fix would be much appreicated.

Regards,

Carl

Offline Repair-man

  • Technician
  • Member Since: Feb 2008
  • Posts: 3020
  • Country: us
  • The Virtual Repairman
    • The Virtual Repairmans Appliance Help
Re: Beko Fridgefreezer
« Reply #1 on: June 16, 2009, 08:11:05 AM »
This indicates an insulation issue with the cabinet. Since this is not an American product, you would be best suited to find a board that deals with this obscure brand. Have you contacted the manufacturer yet?


Try this link for a manual...

Beko Refrigerators
"It's only expensive if someone else fixes it for you" -
The Virtual Repairman   www.repair2000.com

Offline Icehouse

  • Technician
  • Member Since: Oct 2008
  • Posts: 566
    • hvacbob
Re: Beko Fridgefreezer
« Reply #2 on: June 17, 2009, 02:40:47 PM »
GE had a similar issue with their cycle defrost units. The cure was to thaw the unit completely and heat up the area with a heat gun. Afterwards we used a spray in foam insulation and unless under warranty was expensive.  :tickedoff:
NATE, NCCER, PHCC,HVAC Certified Instructor
Member RSES, US Army Refrigeration Specialist(Retired), Former Refrigeration Teacher NYC Board of Ed.
a tragedy has happen to me : http://web.me.com/zenzoidman/Bobice/