Author Topic: Kenmore HD Elite Top Load Washer not rinsing!!!  (Read 1553 times)

Offline sunnybono

  • VIP Member
  • Member Since: Dec 2008
  • Posts: 11
Kenmore HD Elite Top Load Washer not rinsing!!!
« on: May 30, 2009, 11:03:14 AM »
I'm back again.  Last time you guys helped me solve my agitator (motor coupler) issue.  Now the washing machine won't run thru the rinse cycle.  I can hear the timer humming but no water.  Everything else, agitator, fill up, spin cycle works, just that the dial gets stuck on rinse and no rinse function!!
Please help. I really like this machine and I'm not about to give up on it yet!!!!

SK

Model 110.20956991

Offline whirlpooltech

  • Technician
  • Member Since: Nov 2007
  • Posts: 1367
  • Country: us
  • 20 years of experience
Re: Kenmore HD Elite Top Load Washer not rinsing!!!
« Reply #1 on: May 30, 2009, 11:10:44 AM »
Your washer uses cold water for the rinse cycle.

The timer will not advance through the rinse cycle until the correct water level has been reached.

If your washer is not filling during the rinse cycle I would check the screen in the water valve to see if it's plugged.

Unplug the washer. Turn the water off at the shut off valves and remove the cold water hose from the back of the washer. Look inside the valve were you just removed the hose. You will see that there is a fine stainless steel screen in the valve.

It's probably all plugged up with crap. You can remove the screen by just pulling it out. Rinse the screen off under some water and place it back in the valve.

It would also not hurt to check out the one on the hot water side too.

If the screens are clean and your still not getting any cold water during the rinse cycle you will need to replace the water fill valve.

Let us know what you find.  

Offline sunnybono

  • VIP Member
  • Member Since: Dec 2008
  • Posts: 11
Re: Kenmore HD Elite Top Load Washer not rinsing!!!
« Reply #2 on: May 30, 2009, 11:22:06 AM »
Not So Loud PLEASE ;D ;D

I feel like such a heel!!!!  I purposely turned off the cold water when washing my jeans.  I didn't realize that the rinse runs on the cold water!!!  All is working fine now.  Between you and I, I told the wife that I fixed it!!!! O0 O0 O0 O0

Offline whirlpooltech

  • Technician
  • Member Since: Nov 2007
  • Posts: 1367
  • Country: us
  • 20 years of experience
Re: Kenmore HD Elite Top Load Washer not rinsing!!!
« Reply #3 on: May 30, 2009, 11:26:39 AM »
It happens. :)

donate
$1, $2, $5, $10, $20, $50
 

Kenmore HD Elite Top Load Washer

Started by sunnybono

Replies: 16
Views: 4791
Last post December 29, 2008, 05:30:35 PM
by Repair-man
kenmore elite front load washer wont spin completely dry

Started by monki

Replies: 14
Views: 9659
Last post April 02, 2012, 10:48:48 AM
by JWWebster
kenmore elite front load washer wont spin completely dry

Started by dcdang

Replies: 2
Views: 1534
Last post September 24, 2011, 11:22:31 PM
by dcdang
kenmore elite front load washer

Started by jab4558

Replies: 11
Views: 509
Last post May 01, 2014, 08:27:05 PM
by niobrara
Frigidiare Kenmore Front Load Washer Inner Tub & Tub Bearing Replacement.

Started by AJ

Replies: 5
Views: 6762
Last post March 03, 2008, 03:56:05 AM
by BrntToast
lint on clothes at end of wash. kenmore washer top load

Started by KMZK

Replies: 3
Views: 3221
Last post March 11, 2008, 10:59:49 PM
by BrntToast