Author Topic: Please help!! Not sure if I removed GE oven heating elements properly  (Read 1803 times)

Offline ratdog

  • VIP Member
  • Member Since: May 2009
  • Posts: 5
Hi folks,

Please provide advice...I fear I may have ruined my built-in GE oven.

The oven started to heat set to bake yesterday, but then stopped.  Some time ago the broiler element stopped working.  I had read something about pulling out a heating element and testing with a multimeter.  I removed the 2 screws that attach the bottom element to the back of the oven.  Then I started pulling the element out.  There was some small resistance but I could not see anything in the hole except for what looks like insulation, which I didn't disturb.  However, now I can't see to find what I thought would be slots to plug the element back in.  The white insulation appears to go back at least 1 inch.  

Can some please help me figure out what I have possibly done wrong?  And how to fix this?  I couldn't imagine that the insulation needs to be removed.      

Thanks so much,

Richard

Model JTP45W0A1WW

Offline Mr. Fix-It

  • Technician
  • Member Since: Jan 2009
  • Posts: 357
What you've done is pulled the wires loose from the element there is no socket. You now have pull the oven right out from the wall and access the terminals from the back. Not a fun job it's always bugged me that they don't make the wires long enough to do these things from the inside.

Offline ratdog

  • VIP Member
  • Member Since: May 2009
  • Posts: 5
Much appreciated, Mr. Fix-it....

That's what I was afraid of.  I didn't have enough imagination to suspect GE would make disconnecting the elements so difficult, and had thought there was a socket like you might find on a range burner.

Is it likely I may have damaged the wires by pulling the element out from the front rather than going into the back?

I have found the original installation instructions for the oven (it's a double).  Can anyone provide an idea of what's involved in removing the oven to get to the back, such as weight, two or more people, things to watch out for, etc?

Thanks again,
Richard

Offline ratdog

  • VIP Member
  • Member Since: May 2009
  • Posts: 5
Hi again...

From looking at the oven, all I can see is screws running along the inside that fasten to the cabinet.  Could that be all?

 Also, the instructions note that the door (or doors...only the top is marked) must be removed before installation.  Would they then need removal before pulling the oven out too?

Thanks,
Richard

 

Jenn-Air Gas Oven not Heating Properly.

Started by TechnicianBrian

Replies: 0
Views: 2880
Last post December 14, 2008, 02:21:32 PM
by TechnicianBrian
GE oven not heating properly

Started by Tailspin

Replies: 11
Views: 10329
Last post March 15, 2009, 04:06:52 PM
by Tailspin
Whirlpool Oven Not Heating Properly

Started by Crash55

Replies: 10
Views: 1379
Last post January 31, 2013, 05:07:47 PM
by Crash55
Kitchenaid Oven not Heating after Self Cleaning

Started by TechnicianBrian

Replies: 0
Views: 3199
Last post August 27, 2008, 06:46:01 AM
by TechnicianBrian
JBP67W0H1WW GE-Oven/Range-not heating

Started by sunshine33467

Replies: 9
Views: 4807
Last post September 28, 2008, 03:47:46 AM
by RegUS_PatOff
Frigidaire Oven upper element not fully heating up on bake cycle

Started by prconsulting

Replies: 2
Views: 3167
Last post December 28, 2008, 09:20:32 AM
by jumptrout51