Author Topic: Whirlpool Electric Range - Bake Cycle Not Working  (Read 2692 times)

Offline AJ

  • Technician
    Administrator
  • Member Since: Jun 2007
  • Posts: 9240
  • Country: us
    • ApplianceJunk.com - Appliance Repair Help
Whirlpool Electric Range - Bake Cycle Not Working
« on: January 01, 2008, 03:44:30 PM »
Model Number: RF365BXYN1 icon


Complaint: The customers complaint on this oven was that she could not get the oven to heat up when she put it on bake.

I put the oven into bake and the bake element would not heat up.
I then put the oven on broil to see if the broil element come on. The broil element did come on and get read hot. This told me that the voltage (220-240Vac) to the oven was ok.

I then disconnected the power to the range and removed the bake element.
Checking the bake element with a ohm meter it tested open.

Installed a new bake element and tested the oven. Everything was once again working like new.



« Last Edit: March 16, 2008, 06:33:49 PM by AJ »
Follow us on Google+ to see updates from our Google Drive and more!

 

Whirlpool electric range hidden bake element

Started by Jerry

Replies: 2
Views: 4139
Last post December 01, 2008, 07:14:22 PM
by AJ
Whirlpool Range RF364PXYQ2 oven does not heat during the bake cycle

Started by AJ

Replies: 0
Views: 821
Last post January 04, 2012, 05:08:51 PM
by AJ
Whirlpool Range - Top Burner Not Working

Started by AJ

Replies: 0
Views: 3073
Last post December 28, 2007, 12:21:08 AM
by AJ
lg electric range: "start" button stopped working

Started by birch

Replies: 4
Views: 7926
Last post February 28, 2010, 11:28:41 PM
by john63
Whirlpool Range Bake Element Not Heating

Started by TechnicianBrian

Replies: 0
Views: 1562
Last post April 08, 2008, 07:08:16 AM
by TechnicianBrian
Whirlpool Range Surface Element not Working

Started by TechnicianBrian

Replies: 0
Views: 2353
Last post June 04, 2008, 11:06:40 PM
by TechnicianBrian