Author Topic: Electic Oven - No Heat  (Read 2517 times)

Offline tater215

  • VIP Member
  • Member Since: Feb 2009
  • Posts: 4
Electic Oven - No Heat
« on: February 12, 2009, 10:31:09 AM »
Turned the oven on the other day and no heat.  Tried broil ... no heat.  All stove top burners work fine.  Used to when the oven was started a heating light would come on and relay clicks could be heard.  Now the light comes on and no relay clicks.  Elements seem good.  Is the control board faulty?  Any other causes?

Model Number: rf378pxgw icon

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8781
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Electic Oven - No Heat
« Reply #1 on: February 12, 2009, 11:41:44 PM »
Probaby but check the breaker and receptacle before buying exspensive controls.
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline Repair-man

  • Technician
  • Member Since: Feb 2008
  • Posts: 3020
  • Country: us
  • The Virtual Repairman
    • The Virtual Repairmans Appliance Help
"It's only expensive if someone else fixes it for you" -
The Virtual Repairman   www.repair2000.com

Offline tater215

  • VIP Member
  • Member Since: Feb 2009
  • Posts: 4
Re: Electic Oven - No Heat
« Reply #3 on: February 17, 2009, 08:02:17 AM »
Since the burners work fine I don't think it is a plug or breaker issue.  I have flipped the breaker a few times and well as unplugged the appliance and plugged it back in.

With regards to other thread the model I have does not seem to have any fuse or overtemp thermostat.

I ordered a replacement elec-cntrl yesterday and should have it in late this week or early next.

Over the weekend I tried the self clean function.  Everything appeared to be working correctly just no heat.  The door locked, door locked light came on, timer worked ... just no heat.  Although it was not visually recognizable I just think something on the board is smoked.

Offline tater215

  • VIP Member
  • Member Since: Feb 2009
  • Posts: 4
Re: Electic Oven - No Heat
« Reply #4 on: February 20, 2009, 02:09:13 PM »
Got the new controls and fixed everything.  Prior to purchasing I took the back off and made sure no wires were burnt.  The stove top burners worked, all the lights, timers appeared to be working fine.  I even ran the clean feature and it locked and unlocked the door and the heating light illuminated.  Just no heat to either burner and no audible click from the relays.  Thanks for your help and I hope that this will help someone else.

Offline jumptrout51

  • Technician
  • Member Since: Nov 2007
  • Posts: 1879
  • Country: us
    • Buy me a beer through paypal
Re: Electic Oven - No Heat
« Reply #5 on: February 20, 2009, 03:01:30 PM »
Which parts did you purchase?
Take a Kid fishing.

Offline tater215

  • VIP Member
  • Member Since: Feb 2009
  • Posts: 4
Re: Electic Oven - No Heat
« Reply #6 on: February 23, 2009, 10:02:12 AM »
I bought the new electronic control.  The item with the clock and push buttons.  I got one for about $110 refurbished.  It was expensive but not as much as a new stove.


 

Whirlpool Buit-In Oven - No heat

Started by AJ

Replies: 0
Views: 2822
Last post December 28, 2007, 07:41:25 AM
by AJ
Kitchenaid KEBC107 Oven No Heat

Started by thepicker

Replies: 5
Views: 8245
Last post January 16, 2008, 04:00:06 PM
by RegUS_PatOff
Kitchenaid Double Oven no Heat after Self Clean

Started by TechnicianBrian

Replies: 0
Views: 5402
Last post November 18, 2008, 02:03:23 PM
by TechnicianBrian
Whirlpool Oven Will Not Heat

Started by mknepper

Replies: 6
Views: 2441
Last post September 15, 2011, 01:14:33 PM
by JWWebster
oven will not heat over 205 deg

Started by cjbough

Replies: 13
Views: 3334
Last post July 30, 2009, 05:48:44 PM
by whirlpooltech
HBL 645 AUC Bosch oven will not heat up but does blow air

Started by cynthia

Replies: 0
Views: 2922
Last post September 30, 2009, 12:00:37 PM
by cynthia