Author Topic: Oven not working  (Read 1471 times)

Offline vach1974

  • VIP Member
  • Member Since: Jan 2009
  • Posts: 2
Oven not working
« on: January 28, 2009, 08:39:08 PM »
Everything on the cook top works including digital display...but niether the  broiler element or the the bake element are turning on..Im thinking thermostat/temp probe..any thoughts or ideas are appec....thanks in advance

Model 790.95032503

Offline Repair-man

  • Technician
  • Member Since: Feb 2008
  • Posts: 3020
  • Country: us
  • The Virtual Repairman
    • The Virtual Repairmans Appliance Help
Re: Oven not working
« Reply #1 on: January 28, 2009, 08:44:01 PM »
A little more, please...

Any chance you recently performed a self-clean?

Any error codes?

Does the display indicate Bake when turned on?
« Last Edit: January 28, 2009, 08:49:00 PM by Repair-man »
"It's only expensive if someone else fixes it for you" -
The Virtual Repairman   www.repair2000.com

Offline vach1974

  • VIP Member
  • Member Since: Jan 2009
  • Posts: 2
Re: Oven not working
« Reply #2 on: January 28, 2009, 09:14:20 PM »
I have no self clean option, no error codes, and the bake temp is on.TIA

Offline Repair-man

  • Technician
  • Member Since: Feb 2008
  • Posts: 3020
  • Country: us
  • The Virtual Repairman
    • The Virtual Repairmans Appliance Help
Re: Oven not working
« Reply #3 on: January 28, 2009, 09:18:27 PM »
So if the top burners work, we know you have 240 volts. This means either the clock is not sending out voltage to the  bake element or the elements are bad. Easy enough to find out with your meter.

Unplug it and test the elements for continuity. If they are good replace the clock.

"It's only expensive if someone else fixes it for you" -
The Virtual Repairman   www.repair2000.com

 

Oven not working

Started by Ryan

Replies: 9
Views: 2427
Last post October 06, 2008, 05:34:14 AM
by Repair-man
Whirlpool Gold Oven Controls Not Working

Started by vacmechanic

Replies: 2
Views: 4568
Last post December 14, 2008, 11:44:07 AM
by AJ
Whirlpool Oven Light Not Working

Started by Scotts Elle

Replies: 3
Views: 3387
Last post December 31, 2008, 06:52:03 PM
by RegUS_PatOff
Kenmore Elite Double Oven convection fan not working

Started by ch3ris

Replies: 6
Views: 3742
Last post July 02, 2010, 05:10:22 PM
by JWWebster
Frigidaire Electric Double Wall Oven - Elements stopped working one by one

Started by adam2u

Replies: 1
Views: 2581
Last post August 03, 2010, 06:44:37 PM
by JWWebster
Frigidaire Oven, Top and Bottom Elements stopped working -- Fixed

Started by bio132

Replies: 1
Views: 2309
Last post September 24, 2010, 12:28:36 PM
by AJ