Author Topic: KitchenAid not cooking lights flash  (Read 1144 times)

Offline derrsmichael

  • VIP Member
  • Member Since: Jan 2009
  • Posts: 3
KitchenAid not cooking lights flash
« on: January 21, 2009, 03:21:17 PM »
I am a repair tech. I am diagnosing a kitchenaid KHHC2090SBL0. This is my first inverter microwave. The unit will run but not cook. The hood lights flash when its running. I have check the door switches and thermostats. I have more than .05 amps when running but the amp draw is eratic. I get 119 v to the inverter. The inverter make a sound like it's cycling a charge. The magnetron tested good. I have had mags that test good but are not. I don't know if the inverter is working. How determine if I have a bad Magnetron or a bad inverter.

Model Number: KHHC2090SBL0 icon

Offline Whirlpool®

  • VIP Member
  • Member Since: Jan 2009
  • Posts: 10
    • Whirlpool.com
Re: KitchenAid not cooking lights flash
« Reply #1 on: January 27, 2009, 01:37:52 PM »

Offline derrsmichael

  • VIP Member
  • Member Since: Jan 2009
  • Posts: 3
Re: KitchenAid not cooking lights flash
« Reply #2 on: January 28, 2009, 12:40:05 AM »
I have checked the inverter for loose connections or burnt components. Nothing appears to be loose or burnt. So I am going to replace the magnetron and pray. I had the tech. sheet. It is not much help in diagnosing the inverter.

 

Kitchenaid Range no Oven Lights

Started by TechnicianBrian

Replies: 0
Views: 3384
Last post May 20, 2008, 10:03:36 PM
by TechnicianBrian
GE gas range pilot lights

Started by jumptrout51

Replies: 1
Views: 5289
Last post November 29, 2007, 02:37:10 PM
by Pegi
Maytag Double Wall oven lights

Started by jumptrout51

Replies: 2
Views: 4810
Last post December 23, 2007, 01:26:06 PM
by kjagmin
Kitchenaid KEBC107 Oven No Heat

Started by thepicker

Replies: 5
Views: 8485
Last post January 16, 2008, 04:00:06 PM
by RegUS_PatOff
Kitchenaid Vent Keeps Going Up & Down

Started by TechnicianBrian

Replies: 1
Views: 1983
Last post February 27, 2013, 03:21:23 PM
by Rick32k
Kitchenaid Microwave Not Heating

Started by TechnicianBrian

Replies: 0
Views: 4781
Last post April 10, 2008, 09:58:25 PM
by TechnicianBrian