Author Topic: Whirlpool Gold Oven Controls Not Working  (Read 4924 times)

Offline vacmechanic

  • VIP Member
  • Member Since: Oct 2008
  • Posts: 4
Whirlpool Gold Oven Controls Not Working
« on: December 13, 2008, 11:19:43 PM »
Good Evening, I have a Whirlpool Gold Stove/ Oven Combo Model#GY396LXPQ00. The oven controls have quit working. The clock display is fine and the stove works great, but no other buttons or functions do. I can't even access the diagnostic displays. Any help would be appreciated. VM

Model Number: GY396LXPQ00 icon

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Whirlpool Gold Oven Controls Not Working
« Reply #1 on: December 14, 2008, 11:36:51 AM »
Maybe your breaker needs reset. Killing the power makes the electronics reset sometimes. Try turning off the stove for a while.
« Last Edit: December 14, 2008, 11:38:28 AM by JWWebster »
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline AJ

  • Technician
    Administrator
  • Member Since: Jun 2007
  • Posts: 9422
  • Country: us
    • ApplianceJunk.com - Appliance Repair
Re: Whirlpool Gold Oven Controls Not Working
« Reply #2 on: December 14, 2008, 11:44:07 AM »
Sounds like you need to replace the Oven Control/clock Part Number: AP3717733icon.
Hope you find our site helpful.

 

Whirlpool Oven Light Not Working

Started by Scotts Elle

Replies: 3
Views: 3721
Last post December 31, 2008, 06:52:03 PM
by RegUS_PatOff
Whirlpool Gold 30" Freestanding Oven

Started by MajorApp

Replies: 2
Views: 1576
Last post January 21, 2010, 08:26:37 AM
by MajorApp
Whirlpool Range - Top Burner Not Working

Started by AJ

Replies: 0
Views: 4036
Last post December 28, 2007, 12:21:08 AM
by AJ
Whirlpool Buit-In Oven - No heat

Started by AJ

Replies: 0
Views: 2700
Last post December 28, 2007, 07:41:25 AM
by AJ
Whirlpool Electric Range - Bake Cycle Not Working

Started by AJ

Replies: 0
Views: 3632
Last post January 01, 2008, 03:44:30 PM
by AJ
Whirlpool Range No Oven Operation

Started by TechnicianBrian

Replies: 5
Views: 3598
Last post April 24, 2008, 01:32:13 PM
by JWWebster