Author Topic: GE Profile Microwave Problem  (Read 1736 times)

Offline NormanB

  • VIP Member
  • Member Since: Nov 2008
  • Posts: 1
GE Profile Microwave Problem
« on: November 26, 2008, 11:54:34 AM »
I have a GE Profile Microwave, Space Maker 2. It is only 2 years old. For the past few days I have been having a problem. When I start the microwave there is a hum or crackling sound. It only lasts for a second then the microwave operates normally.
This morning, after it made the sound, it would not heat anything up. It would run, the light was on, the vent worked, and the turntable rotated, but it would not heat anything up.
Is this the type of problem that worth calling a repair service, or should I just look for a new microwave?
Thanks

Model JVN 2070SH01

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8781
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: GE Profile Microwave Problem
« Reply #1 on: November 26, 2008, 12:59:53 PM »
Their are basically 3 things to check. The heater element(magnetron), the diode, and the capacitor.
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

 

GE Profile Microwave Service Manual anyone?

Started by rego

Replies: 7
Views: 5496
Last post July 27, 2011, 04:14:15 PM
by tgoods
GE Profile cooktop ignition problem

Started by blwn31

Replies: 1
Views: 2747
Last post November 17, 2011, 02:28:26 PM
by JWWebster
Problem with Hotpoint RVM1435BJ01 Microwave

Started by soup006

Replies: 6
Views: 1448
Last post March 16, 2012, 04:21:43 AM
by ApplianceGuru
PEM31SMSS GE Profile Microwave Paint Peeling

Started by olyteddy

Replies: 1
Views: 686
Last post April 17, 2014, 09:45:38 AM
by Bailey
Jenn-Air self cleaning oven problem

Started by ralphthedog

Replies: 6
Views: 11470
Last post December 13, 2007, 08:15:34 PM
by ralphthedog
Maytag Gemini Temp Sensor Problem

Started by csala

Replies: 3
Views: 5640
Last post December 17, 2007, 10:25:04 PM
by AJ