Author Topic: Whirpool Ice maker not working  (Read 2875 times)

Offline oxford

  • VIP Member
  • Member Since: Jul 2014
  • Posts: 13
Whirpool Ice maker not working
« on: July 15, 2014, 11:44:37 AM »
Alright so another thread about this subject. Maybe you guys can help me out.

I bought a home recently that came with appliances. The fridge is a nice whirpool WSF26C2EXF01. Here is the story, when I bought the home there was obviously no power to the building, I opened the fridge and dumped out the bucket of ice so that it would not melt and make a mess while I got power turned on (ice maker was working with the previous owner as there was ice in the maker and the inspector checked all the appliances). When I got the power turned on the ice maker was now not working at all.

I have replaced the ice maker itself ($200) and still nothing. I have checked the IR sensor and it seems to work on and off. Constant red LED on is good, Flashing means that it should not be making ice from what I've been reading.

I will unplug the fridge, wait a few minutes and plug it back in and the IR checks out. I will come back around 15 minutes later and the IR sensor LED is not even turned on  :tickedoff: :tickedoff: :tickedoff:  or is that normal?

I have also bought the inlet valves (two together, one red one green I believe) but I have not even opened the box because I don't want to waste another $85 if that is not the problem.

Any help is greatly appreciated!


Been reading these two:
http://appliancejunk.com/forums/index.php?PHPSESSID=933f36417f26c3b7b9a912a0c907e420&topic=55.msg166#msg166

http://appliancejunk.com/forums/index.php?topic=44.0
« Last Edit: July 15, 2014, 11:45:36 AM by oxford »

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 1565
  • Country: us
Re: Whirpool Ice maker not working
« Reply #1 on: July 15, 2014, 11:59:21 AM »
This is a newer optic design then the post that you been reading about.Seems they have had problems.

Offline oxford

  • VIP Member
  • Member Since: Jul 2014
  • Posts: 13
Re: Whirpool Ice maker not working
« Reply #2 on: July 15, 2014, 12:07:04 PM »
From what I've been reading these are very problematic (ice maker as a whole). I just want to make sure that it's the IR before spending $200 on some new emitter and receiver boards.



I also have a water softener system if that helps at all.

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 1565
  • Country: us
Re: Whirpool Ice maker not working
« Reply #3 on: July 15, 2014, 12:19:50 PM »
You have to use the tech sheet from the machine to put it in a diagnostic mode to test.The only other thing i can tell you if you buy the parts from appliance parts pro and they do not fix your problem you can return it less shipping.It would be better if whirlpool just used the old optic design.You get both pieces at a lower price.

Offline keithvibe

  • Technician
  • Member Since: Apr 2014
  • Posts: 207
  • Country: us
    • Buy me a beer through paypal
Re: Whirpool Ice maker not working
« Reply #4 on: July 15, 2014, 07:17:42 PM »
Pull the emitter board out on the right hand side unplug the board. Take a jumper wire and jump the middle two wires (if memory serves me correct brown and blue) does the ice maker go in to a harvest with the light switch in the off position?
Where are the ejector fingers in relation to the mold on the ice maker? even with the rake? at the 12o'clock position? where? They should be almost lined up to the rake. Did the water valve fill? Is there ice in the rubber tube? If so you will need to replace the fill valves because you have a weaping water valve.
If the ice maker cycled and stopped almost even with the rake the ice maker is good, if the fill valves sent water to the ice maker, that is good. Only thing left is the emitter board.

Offline oxford

  • VIP Member
  • Member Since: Jul 2014
  • Posts: 13
Re: Whirpool Ice maker not working
« Reply #5 on: July 16, 2014, 10:57:06 AM »
Went over to the house again last night and still no ice.

I also noticed that now no matter what I do (turn off and on) the IR sensor is not lighting up at all.  :'(

I tried to jump the brown and blue wires but my paperclip was too fat, I might try that again tonight.

Here is what I am working with.








If I cannot figure it out by this weekend I might just pay someone to come out and tell me what is wrong and I will fix it myself. Thanks again for any input......  :thanks:

Offline oxford

  • VIP Member
  • Member Since: Jul 2014
  • Posts: 13
Re: Whirpool Ice maker not working
« Reply #6 on: July 21, 2014, 10:42:30 AM »
Bump, New IR sensor board (one with LED). Still no ice  :tickedoff:

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 1565
  • Country: us
Re: Whirpool Ice maker not working
« Reply #7 on: July 21, 2014, 02:00:43 PM »
So when you bought this new ice maker did it come with a new wire harness and if it did.Did you use the new harness.Have you check continuity of the black wire with the ceramic looking fuse from end to end.And i guess this ice maker has not cycle one time sense being installed?

Offline oxford

  • VIP Member
  • Member Since: Jul 2014
  • Posts: 13
Re: Whirpool Ice maker not working
« Reply #8 on: July 21, 2014, 02:55:01 PM »
So when you bought this new ice maker did it come with a new wire harness and if it did.Did you use the new harness.Have you check continuity of the black wire with the ceramic looking fuse from end to end.And i guess this ice maker has not cycle one time sense being installed?

I used the harness that the new ice maker came with.

I have not checked that continuity that you mentioned.

I believe it has not cycled as the fingers are still in the same place as when I installed the ice maker.


I am having an appliance repair man come out and tell me exactly what is wrong, I am having trouble narrowing it down. Keep you guys posted.

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 1565
  • Country: us
Re: Whirpool Ice maker not working
« Reply #9 on: July 21, 2014, 03:19:05 PM »
If you have a old harness and and a old extension cord you can make a cheater cord out of the old harness by using the white wire and black wire with fuse in it and cut out the rest of the wires and keep the molex harness intact by were it plugs into ice maker and attach the extension cord to the other end with a plug and field test ice maker out side the box but you would have to jump out T and H at ice maker module.This just test that the ice maker is able to cycle which i am sure it is .Just thought i would put that out there.

Offline oxford

  • VIP Member
  • Member Since: Jul 2014
  • Posts: 13
Re: Whirpool Ice maker not working
« Reply #10 on: July 21, 2014, 03:20:39 PM »
If you have a old harness and and a old extension cord you can make a cheater cord out of the old harness by using the white wire and black wire with fuse in it and cut out the rest of the wires and keep the molex harness intact by were it plugs into ice maker and attach the extension cord to the other end with a plug and field test ice maker out side the box but you would have to jump out T and H at ice maker module.This just test that the ice maker is able to cycle which i am sure it is .Just thought i would put that out there.


Alright I'll check it out tomorrow. Thanks!

Offline keithvibe

  • Technician
  • Member Since: Apr 2014
  • Posts: 207
  • Country: us
    • Buy me a beer through paypal
Re: Whirpool Ice maker not working
« Reply #11 on: July 21, 2014, 06:59:32 PM »
Have a look at the attachment?
Have you checked to see if you are getting power to the fill valve after forcing a harvest?
The attached PDF should help you

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 1565
  • Country: us
Re: Whirpool Ice maker not working
« Reply #12 on: July 21, 2014, 08:39:50 PM »
Thats the wrong Pdf for his model.This is the ice maker for his model.http://www.appliancepartspros.com/whirlpool-icemaker-w10122576-ap4558158.html
This is the ice maker for your PDF.http://www.appliancepartspros.com/whirlpool-icemaker-w10498261-ap5630984.html
« Last Edit: July 21, 2014, 08:52:32 PM by dab147315 »

Offline keithvibe

  • Technician
  • Member Since: Apr 2014
  • Posts: 207
  • Country: us
    • Buy me a beer through paypal
Re: Whirpool Ice maker not working
« Reply #13 on: July 22, 2014, 05:16:22 AM »
my mistake didn't see a model posted.

Offline oxford

  • VIP Member
  • Member Since: Jul 2014
  • Posts: 13
Re: Whirpool Ice maker not working
« Reply #14 on: July 22, 2014, 12:22:33 PM »
According to the guy that came out today the circuit board on the back of the fridge is acting up. When he tapped on the black boxes (relays I believe they are) the LED kept coming on and off. Something is off back there, need a new one he said.

Time to cough up some more moneys  :'(

 

Video: See if your Whirlpool Ice maker infrared optics control is working.

Started by AJ

Replies: 2
Views: 44696
Last post August 01, 2007, 12:21:37 PM
by AJ
No water from dispenser-ice maker working-replaced valve inlet

Started by Evan

Replies: 2
Views: 4006
Last post August 18, 2007, 05:17:53 PM
by Evan
Whirlpool Gold Ice Maker not working- please help

Started by pudge2824

Replies: 6
Views: 34199
Last post March 04, 2008, 10:00:39 PM
by JWWebster
Whirlpool ice maker stopped working after bucket defrost

Started by stream41

Replies: 23
Views: 8253
Last post December 07, 2012, 12:32:18 PM
by AJ
No water at dispenser - ice maker working fine

Started by drstroud

Replies: 6
Views: 5375
Last post October 30, 2008, 09:37:43 AM
by Repair-man
ice maker not working

Started by LaneBrubaker

Replies: 8
Views: 3376
Last post November 10, 2008, 07:31:05 PM
by LaneBrubaker