Forum > Heating & Air Conditioning Repair

Issue With Carrier 58MVP 100 14120

(1/1)

whitedavidp:
Hello. In a rental property I own (used to be our own home) we have a Carrier furnace installed in 1999 which has been really pretty great. A week ago we had a problem where it simply would not start. It would try to do so and then click off in a cycle over and over again.

A technician came and told me that he found 3 different fault codes. If I got it right they pertained to: low fire pressure switch stuck closed, inducer outside valid speed range, and pressure switch calibration fault. He was, however, able to simply cut power to the furnace and when re-applied all was well again. He said this was common place. Since then, our tenant says the furnace has been operating just fine - better than before. Seems odd but there are circuit cards in there and perhaps, like most computers, they require a reboot now and then.

The other thing the technician said was that this furnace is basically at end-of-life which surprised the heck out of me. He said that repairing this would be very expensive and that replacing is likely the thing to do at this point. I have no way to confirm this one way or the other. It just seems a pretty short lifespan for a unit that was so expensive to begin with and that actually sees use less than 1/2 of the year. Maybe these are just not made like they used to be?

I was called by the service company and they are saying the the inducer assembly and the pressure switch assembly would cost over $1900 installed (1-1.5 hours labor). I have no idea what these entail or should cost. But I do know that in 1999 the cost to install the furnace (along with gas meter/pipe, direct venting, etc) was about $5000. I have to guess that it will be more than that now.

So can anyone speak to these issues? Are the parts prices over-stated? Are they even actually needed since the furnace seems fine since its "reboot"? Should the thing be tossed?

Thanks for your viewpoints.

DaleCaskanette:
if the computer sees a problem it locks out and will not start, turning off the power reset the board if it is working now i would not change it.

Navigation

[0] Message Index

Go to full version