Author Topic: GE Profile Electric Range Bake will not heat....  (Read 622 times)

Offline kevin5189

  • VIP Member
  • Member Since: Feb 2014
  • Posts: 2
GE Profile Electric Range Bake will not heat....
« on: February 01, 2014, 11:17:52 AM »
I have a GE Profile Electric Range Model # JSP39WT1WW, will not heat up during bake but will during broil. When you push the button to bake you hear the bake relay click, then on clock display it shows bake but temperature never gets above 100 degrees. Open the oven door and there is no heat coming from bake element. Checked the bake element with multimeter and it was 21 ohms (Seems Good), voltage going to element shows nothing (red to ground 120, white to ground 0, red to white 0. So I removed the control clock and T1 showing 120V to ground, and wire coming from bake relay 0V to ground. The replacement modelfor the clock is wb275k140 and says they have discontinued this model and appears I have to send this off for repair. My question is have I diagnosed this correctly? Is there something simple I am missing? Who do I send this offfor repair (recomendations)? I believe that there is a bad soldier joint on the board can I repair this? :thanks:

Offline LowSL2

  • Technician
  • Member Since: Dec 2011
  • Posts: 771
  • Country: us
  • Fletch F. Fletch
    • Buy me a beer through paypal
Re: GE Profile Electric Range Bake will not heat....
« Reply #1 on: February 02, 2014, 11:08:05 AM »
If you think it's a bad solder joint, try fixing that first and see if it solves the problem. I'm thinking it's a control board problem.
LowSL2
15 Years of Professional Appliance Repair Experience

Offline kevin5189

  • VIP Member
  • Member Since: Feb 2014
  • Posts: 2
Re: GE Profile Electric Range Bake will not heat....
« Reply #2 on: February 06, 2014, 07:40:19 PM »
Thats what it was bad solder joint. Took plastic off boards and folded them apart. Easy to spot.. cleaned the joint and resoldered. worked perfect!!!
Thanks

Follow us on Google+
 

Whirlpool Electric Range - Bake Cycle Not Working

Started by AJ

Replies: 0
Views: 3139
Last post January 01, 2008, 03:44:30 PM
by AJ
Whirlpool electric range hidden bake element

Started by Jerry

Replies: 2
Views: 4504
Last post December 01, 2008, 07:14:22 PM
by AJ
Kenmore Electric Range-No Bake or Broil

Started by Gobbyparts

Replies: 10
Views: 6301
Last post February 23, 2009, 04:56:02 PM
by RegUS_PatOff
Tappan Electric Range No Bake No Broil

Started by cbmcd2680

Replies: 1
Views: 1536
Last post November 09, 2011, 07:05:52 PM
by theoldstoveguy
Whirlpool Range RF364PXYQ2 oven does not heat during the bake cycle

Started by AJ

Replies: 0
Views: 1040
Last post January 04, 2012, 05:08:51 PM
by AJ
Whirlpool Polara Range--Bake, Convect Bake, Broil and Clean--no heat-no error co

Started by pjgrose

Replies: 16
Views: 3065
Last post June 27, 2012, 09:48:17 PM
by tgoods