Author Topic: Electrolux EW30EF65GSC No Display After Self Clean  (Read 796 times)

Offline LowSL2

  • Technician
  • Member Since: Dec 2011
  • Posts: 827
  • Country: us
  • Fletch F. Fletch
    • Buy me a beer through paypal
Electrolux EW30EF65GSC No Display After Self Clean
« on: January 12, 2014, 11:33:44 PM »
Got a call today about this range with no display after they self cleaned it. They called six companies over the last two months and I was the only one that agreed to look at it. This model has four control boards, two power boards and a variable speed board. The oven UI was blank. But the surface UI had blinking dashes. The wiring diagram shows that each UI board has its own power supply board. There are two identical ones mounted on the back of the range. They both had 120VAC going in. But only one had 8VDC coming out. The one supplying power to the surface control UI. I swapped the supply boards and the oven UI started right up with a F20 comm error(as to be expected). So I ordered a power supply board and will return when it comes in. The last guy they called said he would have to replace all of the control boards because there is no way to test them... I think I have another customer for life. :)

Moral of the story, check the power supply boards on these new Electrolux/ Frigidaire ranges if one of the UI's go out.

Sent from my DROID BIONIC using Tapatalk

EW30EF65GSC
« Last Edit: January 12, 2014, 11:34:37 PM by LowSL2 »
LowSL2
15 Years of Professional Appliance Repair Experience

Offline AJ

  • Technician
    Administrator
  • Member Since: Jun 2007
  • Posts: 9390
  • Country: us
    • ApplianceJunk.com - Appliance Repair
Re: Electrolux EW30EF65GSC No Display After Self Clean
« Reply #1 on: March 09, 2014, 02:42:30 PM »
Good job!  O0
Hope you find our site helpful.

Offline Tom K

  • VIP Member
  • Member Since: Apr 2014
  • Posts: 2
Re: Electrolux EW30EF65GSC No Display After Self Clean
« Reply #2 on: April 29, 2014, 02:06:23 PM »
Read your post on Electrolux Self Cleaning problem.  I have a Fridgidaire Range # FGFL79DBA and Lock will not activate for self cleaning.  I replaced the lock motor and checked latch and motor still did not work.  then replaced oven control board and still motor did not activate.  apparently motor is not getting power.  Would appreciate it if you have any suggestions.  I am an amateur. 

 

Maytag self clean wall oven

Started by MajorApp

Replies: 13
Views: 5359
Last post May 19, 2008, 09:58:15 AM
by MajorApp
GE Microwave No Display, No Operation

Started by TechnicianBrian

Replies: 0
Views: 4809
Last post April 15, 2008, 09:57:53 PM
by TechnicianBrian
Kitchenaid Microwave Crazy Display

Started by TechnicianBrian

Replies: 0
Views: 1754
Last post May 07, 2008, 06:16:37 PM
by TechnicianBrian
RS2466CW1 Display on viking range

Started by 66carlos66

Replies: 3
Views: 2746
Last post August 20, 2008, 06:30:22 AM
by Repair-man
Electrolux Oven Light won't Turn Off

Started by TechnicianBrian

Replies: 0
Views: 7016
Last post September 12, 2008, 07:13:49 AM
by TechnicianBrian
Electrolux Cooktop no Hot Surface Indicator Light

Started by TechnicianBrian

Replies: 0
Views: 3262
Last post September 25, 2008, 01:23:19 PM
by TechnicianBrian