Author Topic: GE Microwave does not heat  (Read 498 times)

Offline Hongbo Ma

  • VIP Member
  • Member Since: Dec 2013
  • Posts: 3
GE Microwave does not heat
« on: December 20, 2013, 12:59:06 AM »
I own over-range microwave oven. Model is GE JNM1951SR1SS. It quit heating. I checked all fuses and thermal cutoffs. Fuses are closed, three thermal are closed and the vent thermal cutoff is open at room temp. Three door switches were intact. Door closes tightly. I noticed cavity light is blown and ordered a new one. Waiting for it to come in. Everything else works fine but heating. Control display is working. cooling fan is working too.

However, when I bypass the vent thermostat by simply connecting the wires, it heats water just fine. Of course, the vent fan turns on and works continuously. Based on this, I assume the HV capacitor and magnetron work just fine. The smart board is the only thing I have not checked. Any thoughts or suggestions on what might be wrong with the microwave? I have exhausted my knowledge. Please help.

Offline tgoods

  • Technician
    Moderator
  • Member Since: Jul 2010
  • Posts: 1444
  • Country: us
    • Buy me a beer through paypal
Re: GE Microwave does not heat
« Reply #1 on: December 22, 2013, 10:23:57 PM »
Since it will heat after bypassing the vent thermostat, I think the problem will on the low voltage side.  Check for a voltage drop across the heat relay on the control board while running. If you see 120vac, the relay is bad. Can you post a picture of the schematic?

Offline Hongbo Ma

  • VIP Member
  • Member Since: Dec 2013
  • Posts: 3
Re: GE Microwave does not heat
« Reply #2 on: December 23, 2013, 01:02:31 PM »
tgoods,

Thanks for replying. Some updates here. I end up with disassembled the door switch and unplug/replug all the cables on the PCB. After I put everything together, the heating worked! Also my light bulb came in and I put it on. I mounted it back to the wall.

I cooked eggs with egg cooker. Then the second day, when I use the microwave to heat up some frozen vegetables, the heating is gone again! damn! This time, I did not touch the door interlocks, just pulled out all the cables and replug them, and heating is back now. Could it be the steam sensor that somehow got triggered by the cooking steam from egg cooker? how to nailed it down?

I attached the schematic and a view of the PCB from the service manual. Appreciate any further insight.

 

Amana Microwave Noisy and No Heat-

Started by mkbabi

Replies: 4
Views: 3335
Last post January 13, 2008, 09:34:14 AM
by Skeeter
GE Spacemaker XL Microwave Won't Heat

Started by Loftus64

Replies: 2
Views: 5368
Last post October 31, 2008, 11:26:01 AM
by Loftus64
Frigidaire Microwave Counts Down but Doesn't Heat.

Started by TechnicianBrian

Replies: 0
Views: 11567
Last post December 22, 2008, 03:54:23 PM
by TechnicianBrian
JT965 microwave/oven wall combo - bottom element will not heat

Started by nahoku02

Replies: 3
Views: 682
Last post September 14, 2013, 10:13:16 AM
by krazytech
KitchenAid microwave KEMC308SS04 does everything it should except heat

Started by hospitalityusa

Replies: 1
Views: 332
Last post March 01, 2014, 05:03:55 PM
by AJ
Whirlpool Buit-In Oven - No heat

Started by AJ

Replies: 0
Views: 1771
Last post December 28, 2007, 07:41:25 AM
by AJ