Author Topic: Ammana SBD20KW evap fan only getting 36 volts  (Read 880 times)

Offline Caddy4343

  • VIP Member
  • Member Since: Oct 2007
  • Posts: 46
Ammana SBD20KW evap fan only getting 36 volts
« on: November 05, 2013, 06:49:16 PM »
Ammana SBD20KW evap fan only getting 36 volts.  I tried replacing the defrost timer but it didn't help.  I'm stumped.  What can reduce the fan voltage?
 
Thanks

Offline Cananot

  • Technician
  • Member Since: May 2013
  • Posts: 116
  • Country: us
  • Technician for 13 years and still getting stumped
    • Buy me a beer through paypal
Re: Ammana SBD20KW evap fan only getting 36 volts
« Reply #1 on: November 05, 2013, 08:01:08 PM »
First off is it a SBD20K-P1117701W model ? Cause wow is there any parts still made for this ??? What it sounds like is you have a burnt wire somewhere and you can't get 120 I ran into a sub zero that had a burnt starter wire and got 120 to the starter but as soon as it cut on it would spark and drop big time and it was crossed with the frig side compressor and would over heat it was crazy..well anyway somewhere in the harness there is a few burnt out strands and cant send 120 cause there is something taken your voltage from the fan

Offline Caddy4343

  • VIP Member
  • Member Since: Oct 2007
  • Posts: 46
Re: Ammana SBD20KW evap fan only getting 36 volts
« Reply #2 on: November 05, 2013, 08:15:40 PM »
Thank you.  I suspected something like that but I needed a second opinion.  It's an old one but has wood panels that match the kitchen cabinets. 

Offline MajorApp

  • Technician
  • Member Since: Feb 2008
  • Posts: 554
  • Country: us
Re: Ammana SBD20KW evap fan only getting 36 volts
« Reply #3 on: November 05, 2013, 10:28:05 PM »
Is this one of the models where the power to the evaporator fan goes through the defrost thermostat?

Offline Cananot

  • Technician
  • Member Since: May 2013
  • Posts: 116
  • Country: us
  • Technician for 13 years and still getting stumped
    • Buy me a beer through paypal
Re: Ammana SBD20KW evap fan only getting 36 volts
« Reply #4 on: November 06, 2013, 06:49:34 AM »
Yes it is and you already replaced the board and if its not defrosting then try replacing the thermo I really doubt you can run a new wire harness thru the shell ..ya custome covers I know those all to well good news is they can get frig that will fit those old covers I did that about a month ago

Offline Caddy4343

  • VIP Member
  • Member Since: Oct 2007
  • Posts: 46
Re: Ammana SBD20KW evap fan only getting 36 volts
« Reply #5 on: November 06, 2013, 05:19:22 PM »
Thanks for the info.  I did check the defrost limiter by, by-passing it.  That's good news about the panels fitting a new refrig.  Thanks. 

Offline RegUS_PatOff

  • Technician
  • Member Since: Dec 2007
  • Posts: 1410
  • Country: us
Re: Ammana SBD20KW evap fan only getting 36 volts
« Reply #6 on: November 06, 2013, 08:32:11 PM »
Amana Evaporator Fan also goes throgh the Defrost Heater ...
does it Defrost work OK ?
After leaving this Earth, "Do you want the smoking or non-smoking section?"

Offline Caddy4343

  • VIP Member
  • Member Since: Oct 2007
  • Posts: 46
Re: Ammana SBD20KW evap fan only getting 36 volts
« Reply #7 on: November 06, 2013, 08:45:13 PM »
Customer shut refrig off so it was only running 20 hours before I looked at it.  Some frost on back wall and the coils were iced up.  Heater checked out ok and as I said; I by passed the defrost limiter, changed the timer and did an amp check on a heater wire but got nothing.  Tested the fan motor with a test cord.  It was ok too.
 
Has to be a burnt wire in the harness.... somewhere.  Time for a new refrigerator.
 
Thanks for everyone's help.  This was a new one on me.  12 years in the business.

Offline Cananot

  • Technician
  • Member Since: May 2013
  • Posts: 116
  • Country: us
  • Technician for 13 years and still getting stumped
    • Buy me a beer through paypal
Re: Ammana SBD20KW evap fan only getting 36 volts
« Reply #8 on: November 06, 2013, 08:55:00 PM »
Shoootttt....its all good least now you know, like you been doing this for a very long time and i get my butt kicked so many times whirlpoo duets beat me down i tell you but thanks to this forum and the people on it we can always get a fresh eye on the problem coming here thanks for sharing  :)

 

Frigidaire Evap Fan motor not working

Started by jumptrout51

Replies: 10
Views: 9336
Last post May 25, 2008, 02:55:57 PM
by JWWebster
Evap fan noisy and bogging and poss no defrost?

Started by jlardino

Replies: 12
Views: 4065
Last post December 11, 2008, 09:54:21 AM
by jlardino
GE DC Evap Fan Motor

Started by thumbrfg

Replies: 15
Views: 6001
Last post April 12, 2009, 06:17:54 AM
by Repair-man
Ge refrigerator evap fan noise

Started by acdoc502

Replies: 3
Views: 3003
Last post August 09, 2009, 05:36:11 PM
by jumptrout51
Repaired Evap. coil on Samsung fridge, now seems to continually run

Started by IDoSeaDoo

Replies: 2
Views: 1776
Last post June 04, 2012, 10:21:28 AM
by JWWebster
G E side by side no fan motor evap comeen on

Started by williesanchez69

Replies: 3
Views: 2351
Last post December 22, 2010, 04:43:16 AM
by williesanchez69