Author Topic: Used gas range problems  (Read 653 times)

Offline ShawnTRD

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 28
Used gas range problems
« on: October 09, 2013, 10:32:55 PM »
So I bought this Frigidaire ES100  (FGF337AUC) used last week. When we use the oven there is a weird smell. I don't think it's the propane. I want to say it smell like hot metal. It's strong for about 10 minutes but then it's just lingering. I check under the broiler and the igniter was glowing orange and took about 5 minutes to light. I seen a youtube video that said orange or red is bad, and that it needs to glow white. Once it's lite the flame is smooth and mostly blue.


Also the burn click a lot before lighting. Like 10 clicks. I turned on all the burners when the oven was on, and all the burners work. But one in 12k vs the others are 9.5k, and they all look about the same. So I'm wondering if the regulator is bad.


What do you think?


Thanks
Shawn

Offline nolazach

  • Technician
  • Member Since: Sep 2011
  • Posts: 347
Re: Used gas range problems
« Reply #1 on: October 11, 2013, 08:57:03 AM »
No it always glows orange, I have never seen in my life a white igniter.

 

5 minutes is way too long, sounds like a low amperage issue.  Your igniter is part number 5303935066  but the much cheaper GE WB2x9998 is an exact replacement for this igniter.  I would swap that first and that should fix the long light problem.

   hmm, but with the burner problem you could have a regulator issue.  I assume your oven was properly set up for propane and not natural gas.   How long are they clicking? 

Offline ShawnTRD

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 28
Re: Used gas range problems
« Reply #2 on: October 12, 2013, 11:26:07 PM »
Well I got a new ignitor and installed it, but the new one is bad.  Tested it with a ohm meter and nothing. So I have a new new one to install tomorrow.

I can see spark from the sideb of the burner and it takes maybe 5 seconds to light at first.  If I turn it off and try again it normally lights right up. I think I'll try tomorrow with a long lighter. That should tell me if it's s good delivery problem.  They told me it was setup for propane.  How can I verify it's setup right? Flame looks good and blue when light.

Offline ShawnTRD

  • VIP Member
  • Member Since: Apr 2009
  • Posts: 28
Re: Used gas range problems
« Reply #3 on: October 17, 2013, 12:26:02 PM »
Well I changed ignitor yesterday. Now it lights in 20-30 seconds, but there is still a smell.

 

Whirlpool drop in electic range temp. problems

Started by thackeray4

Replies: 3
Views: 1800
Last post November 23, 2008, 01:20:36 PM
by AJ
Kenmore Range - Problems with Reheat model 911.95402000

Started by jchilders

Replies: 3
Views: 627
Last post December 15, 2013, 04:16:21 PM
by jchilders
Fisher and Paykel Softtouch Range problems

Started by vr4raz

Replies: 0
Views: 495
Last post March 27, 2014, 04:08:07 PM
by vr4raz
Jenn Air Duel Fuel Range

Started by Diyeng

Replies: 3
Views: 4712
Last post August 22, 2007, 04:24:51 PM
by Pegi
LG Range Service Manual

Started by flyboytyler

Replies: 1
Views: 4206
Last post November 16, 2007, 05:28:51 PM
by AJ
GE gas range pilot lights

Started by jumptrout51

Replies: 1
Views: 4989
Last post November 29, 2007, 02:37:10 PM
by Pegi