Author Topic: Danby Wine Cooler DWC513BLS-1 not working properly  (Read 689 times)

Offline matthew rowland

  • VIP Member
  • Member Since: Sep 2013
  • Posts: 1
Danby Wine Cooler DWC513BLS-1 not working properly
« on: September 15, 2013, 01:03:23 AM »
hi all, my first time on here.  ive read a few older post about issues with these wine coolers. going by those threads and other sites ive replaced the OLP and installed a starter.  (the people who gave it to me apparently messed with it and didnt put the starter back on so i had to get a new one)  well, after installing said parts, the compressor kicked on, and started cooling....so me not really knowing much about appliance repair got all excited......and then it kicked off after a few minutes and now just clicks every few minutes like its trying to kick back on but isnt...all the fans are going and the thermo is set to lowest setting. 

Any input would be greatly appreciated. 

THANKS!!!

 

Danby Wine Cooler Not Working.

Started by Daddygetalong

Replies: 2
Views: 644
Last post July 22, 2014, 04:13:11 PM
by Gargo
DWC283BLS Danby Wine Cooler -- E3 code

Started by sapp4l

Replies: 8
Views: 7015
Last post January 10, 2010, 02:27:41 PM
by sapp4l
DWC283BLS Danby Wine Cooler Frosting Near Capillary Tube / Dryer

Started by sojourner75

Replies: 5
Views: 4232
Last post August 29, 2010, 07:15:52 PM
by Icehouse
DWC283BLS Danby Wine Cooler

Started by onaleehunter

Replies: 4
Views: 3723
Last post December 13, 2010, 11:22:14 PM
by MajorApp
danby wine cooler DWC3509EBLS

Started by mcharry

Replies: 0
Views: 978
Last post July 23, 2011, 08:38:12 AM
by mcharry
Danby Wine Cooler

Started by shooter12

Replies: 4
Views: 1392
Last post June 05, 2012, 10:40:02 PM
by AJ