Author Topic: Bake Element not working. Is it the thermostat or controller board?  (Read 2205 times)

Offline tgoods

  • Technician
    Moderator
  • Member Since: Jul 2010
  • Posts: 1526
  • Country: us
    • Buy me a beer through paypal
I still think is just the relay.  Relays fail in two ways, either they fail to close or they stay closed and fail to open.  You have a relay that's doing both.

Offline AppTek

  • Technician
  • Member Since: May 2012
  • Posts: 60
  • Country: ca
Tgoods, I never thought of that. Very possible. I have not seen any stuck closed yet myself but if the relay is broken inside, the switch could be floating around.

Offline leorosi

  • VIP Member
  • Member Since: May 2013
  • Posts: 4
Agreed thats its the relay but now I have think about if its worth the time and effort to try and repair it. I'm good with soldering but I have no
idea which relay it is and where I would get replacement relays. If the relays cost like $20 then I can see its worth the effort but otherwise maybe getting a new board is in order but hard to swallow at $300 when cheap relay is the trick...Any ideas about where to get relays and how to test them? Thanks

Offline leorosi

  • VIP Member
  • Member Since: May 2013
  • Posts: 4
And now things get more complicated. I looked at the diagram of my oven again:

 http://www.appliancepartspros.com/body-parts-for-frigidaire-cpeb30s9fc1.html

And there is a part #112 that is labeled Relay.Is this the relay that might need to be replaced or ones on the controller board? I have no clue waht relay part #112 is for?

Offline tgoods

  • Technician
    Moderator
  • Member Since: Jul 2010
  • Posts: 1526
  • Country: us
    • Buy me a beer through paypal
In the schematic, I see a separate relay for the cooling fan.  The relay for the bake element is on the control board right next to the Bake terminal.  You should be able to find a part number on it.  I get my relays from Mouser.com.

 

MayTag Gemini Lower Bake Element Not Working

Started by Crtapp

Replies: 0
Views: 220
Last post November 19, 2014, 08:55:49 PM
by Crtapp
Whirlpool Electric Range - Bake Cycle Not Working

Started by AJ

Replies: 0
Views: 4158
Last post January 01, 2008, 03:44:30 PM
by AJ
Whirlpool Range Bake Element Not Heating

Started by TechnicianBrian

Replies: 0
Views: 2487
Last post April 08, 2008, 07:08:16 AM
by TechnicianBrian
Whirlpool Range Surface Element not Working

Started by TechnicianBrian

Replies: 0
Views: 3289
Last post June 04, 2008, 11:06:40 PM
by TechnicianBrian
Whirlpool electric range hidden bake element

Started by Jerry

Replies: 2
Views: 5438
Last post December 01, 2008, 07:14:22 PM
by AJ
Frigidaire Oven upper element not fully heating up on bake cycle

Started by prconsulting

Replies: 2
Views: 4042
Last post December 28, 2008, 09:20:32 AM
by jumptrout51