Author Topic: Frigidaire Evap Fan motor not working  (Read 9149 times)

Offline jumptrout51

  • Technician
  • Member Since: Nov 2007
  • Posts: 1879
  • Country: us
    • Buy me a beer through paypal
Frigidaire Evap Fan motor not working
« on: May 25, 2008, 08:54:39 AM »
Evaporator fan motor was burned out. Installed a new fan motor. It did not work. Reading 106 volts at molex connector in freezer section.
When you connect the fan motor volts go to "0".
Efan motor volts come from the defrost control.
If you initiate defrost 120 volts are read across the defrost terminals. That side of defrost board is putting out full voltage.
My question is: can the defrost control be bad on the e fan leg causing the lower voltage?
and why does voltage go to "0" when the good fan motor is connected?

Model frs26r2aw3
Take a Kid fishing.

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Frigidaire Evap Fan motor not working
« Reply #1 on: May 25, 2008, 09:37:53 AM »
I do not know for sure but it may be that the evap fan ain't gonna kick in until the terminator gets down to 25 degrees
Just a guess.
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline jumptrout51

  • Technician
  • Member Since: Nov 2007
  • Posts: 1879
  • Country: us
    • Buy me a beer through paypal
Re: Frigidaire Evap Fan motor not working
« Reply #2 on: May 25, 2008, 09:52:06 AM »
The neutral wire splits at the molex connector.
One wire goes to the defrost terminator, the other to the neutral side of the fan from the molex connector.
The defrost stat wire then goes directly to the def. heater neutral side.
My first thought was the same as yours, but it is not wired thru the def. stat.
Take a Kid fishing.

Offline Al Capone

  • Administrator
  • VIP Member
  • Member Since: Feb 2008
  • Posts: 409
  • Country: us
    • ApplianceJunk.com
Re: Frigidaire Evap Fan motor not working
« Reply #3 on: May 25, 2008, 10:05:31 AM »
Here is the wiring diagram.

Wish I could be of more help.

RepairClinic.com - Order now for same day shipping. 365 day return policy!

AppliancePartsPros.com - Over 1 Million Appliance Parts In-Stock. 365-Day Hassle Free Return Policy!

Offline whirlpooltech

  • Technician
  • Member Since: Nov 2007
  • Posts: 1367
  • Country: us
  • 20 years of experience
Re: Frigidaire Evap Fan motor not working
« Reply #4 on: May 25, 2008, 10:08:09 AM »
I would replace the Adaptive Defrost Control (ADC)
Unless there is a bad connection someplace I don't see how it could be any else.


Offline jumptrout51

  • Technician
  • Member Since: Nov 2007
  • Posts: 1879
  • Country: us
    • Buy me a beer through paypal
Re: Frigidaire Evap Fan motor not working
« Reply #5 on: May 25, 2008, 10:11:21 AM »
I would replace the adaptive defrost.
Unless there is a bad connection someplace I don't see how it could be any else.
That is exactly my thought.
But, for learning purposes...why does voltage drop to zero when the fan motor is attached to its wire leads?
Take a Kid fishing.

Offline whirlpooltech

  • Technician
  • Member Since: Nov 2007
  • Posts: 1367
  • Country: us
  • 20 years of experience
Re: Frigidaire Evap Fan motor not working
« Reply #6 on: May 25, 2008, 10:18:42 AM »
Have you looked at the defrost board for any damage?

I see a lot of these boards get damaged from power surges and from compressors that short out.

Hard to say sometime with electronic boards why they do what they do when they are bad.


Offline whirlpooltech

  • Technician
  • Member Since: Nov 2007
  • Posts: 1367
  • Country: us
  • 20 years of experience
Re: Frigidaire Evap Fan motor not working
« Reply #7 on: May 25, 2008, 10:19:48 AM »
It does not help that we only get a block diagram for the adaptive defrost from Frigidaire.

Offline jumptrout51

  • Technician
  • Member Since: Nov 2007
  • Posts: 1879
  • Country: us
    • Buy me a beer through paypal
Re: Frigidaire Evap Fan motor not working
« Reply #8 on: May 25, 2008, 10:36:09 AM »
This house did have a voltage spike according to the electrician.
This call occured yesterday Saturday at a beach house awaiting the arrival of 10 house guest.
Being a holiday weekend I did the only thing I could think of to get them by until next week when more parts would be available.
I drilled a hole thru the back of the freezer compartment, attached a cord to the fan motor and plugged in to a wall outlet.
I will be going back next week with a defrost control.
I am certain this will correct the problem.
I still want to understand the voltage absence when the fan motor is plugged in.
« Last Edit: May 25, 2008, 10:38:24 AM by jumptrout51 »
Take a Kid fishing.

Offline RegUS_PatOff

  • Technician
  • Member Since: Dec 2007
  • Posts: 1410
  • Country: us
Re: Frigidaire Evap Fan motor not working
« Reply #9 on: May 25, 2008, 11:15:13 AM »
Electronic devices sometimes do that when they go bad.
It may be able to supply 106v with no load (or a very small load), but when the fan is connected, the amperage that the fan needs is too high for the (failed) electronic device.

The same thing would happen if you connected a high value resistor in series, such as a 270K OHM, with the 120v line and measured it with your meter, but then when you connect a load, such as the fan, it would drop to nearly 0 volts.

You could temporarily connected the Evaporator Fan to pin E3, so it only runs when the Compressor & Condenser Fan runs.

You wouldn't want it to run when the Defrost Cycle runs (if that still works)



« Last Edit: May 25, 2008, 03:20:15 PM by RegUS_PatOff »
After leaving this Earth, "Do you want the smoking or non-smoking section?"

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Frigidaire Evap Fan motor not working
« Reply #10 on: May 25, 2008, 02:55:57 PM »
From the diagram that Al posted I would say the fan runs through that crappy defrost board that we all have been saying for years should not have been mounted inside the icebox. Change the adaptive defrost control or at least yank it out and clean the green corosion off the teminals with alcohol and reinstall it. It might start working.
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

 

Frigidaire 'NextGen' SxS w/ADC - intermittent evap fan motor operation

Started by JADsvc1

Replies: 3
Views: 1247
Last post November 29, 2012, 05:15:23 PM
by haroldsappliance
GE DC Evap Fan Motor

Started by thumbrfg

Replies: 15
Views: 5780
Last post April 12, 2009, 06:17:54 AM
by Repair-man
240397101 Frigidaire Refrigerator Condenser Fan Motor

Started by AJ

Replies: 0
Views: 2892
Last post October 03, 2009, 12:41:46 PM
by AJ
5304445861 Frigidaire Refrigerator Evaporator Fan Motor

Started by AJ

Replies: 0
Views: 3783
Last post October 03, 2009, 12:51:14 PM
by AJ
G E side by side no fan motor evap comeen on

Started by williesanchez69

Replies: 3
Views: 2298
Last post December 22, 2010, 04:43:16 AM
by williesanchez69
Freezer evap motor replacement- rpms?

Started by tcape

Replies: 3
Views: 2511
Last post April 14, 2011, 03:42:51 PM
by tcape