Forum > Range, Oven & Cooktop Repair

Lights Go out

(1/1)

app1:
Hello, I am working on a Kenmore Electric Range and the Model# 629.46799891 - The Red Surface Light stays on all the time and I believe that this is caused by a bad burner or is it in one of the switches? How do I test them? ALSO, here is the weird part-- The front panel or clock will be fine and then when I set the Bake or Broil to heat it will heat for  a while and the the lights on the display will go out and if I hit the panel they come back on and start heating agai... Bad Board?? or What?
Thanks In Advance For Any Help!!

AJ:

--- Quote ---The Red Surface Light stays on all the time and I believe that this is caused by a bad burner or is it in one of the switches?
--- End quote ---

Replace the burner. If you take a look at one of the burners, such as part # 12002141 you will notice the white probe inside the burner. That is what has failed and is keeping the hot surface light on. To test it you could ohm it out. Compare it to the other burners that are fine.


--- Quote ---ALSO, here is the weird part-- The front panel or clock will be fine and then when I set the Bake or Broil to heat it will heat for  a while and the the lights on the display will go out and if I hit the panel they come back on and start heating agai... Bad Board?? or What?
--- End quote ---

Maybe a bad solder connection on the clock/board. If I could not find any bad connection then I would replace the clock, part # 5760M205-60

Hope that helps.

Let us know how it turns out or if you have any other questions.

app1:
Thank You AJ as it was the board/clock and the small burner, parts are ordered and will be fixed by Thursday!!!
Thanks Again.... :)

Navigation

[0] Message Index

Go to full version