365-Day Hassle Free Return Policy!  ·  AppliancePartsPros.com
Washer PartsDryer PartsRefrigerator PartsDishwasher PartsRange & Oven PartsAll Appliance Parts

Author Topic: Whirlpool Oven Not Heating Properly  (Read 2921 times)

Offline Crash55

  • VIP Member
  • Member Since: Jan 2013
  • Posts: 7
  • Country: us
Re: Whirlpool Oven Not Heating Properly
« Reply #10 on: January 31, 2013, 05:07:47 PM »
It used to be at temperature (or at least feel that way) after the preheat time.  It is definitely cooler now after preheat than before.

I allowed it at a set temperature until it stabilized and it wasn't at the set temperature.  If set for 415F it would stabilize at around 400.  To get it to stabilize at 450F it had to be set to 470F.

I ordered a new control board.  Hopefully that will fix it.

When I first moved into the house the oven would trip the breaker if I tried to self clean it or run stove top and oven. I found that the pigtail was not correctly connected and was arcing.  I think the surges from this may have damaged the control board.

 

Jenn-Air Gas Oven not Heating Properly.

Started by TechnicianBrian

Replies: 0
Views: 4261
Last post December 14, 2008, 02:21:32 PM
by TechnicianBrian
GE oven not heating properly

Started by Tailspin

Replies: 11
Views: 12476
Last post March 15, 2009, 04:06:52 PM
by Tailspin
Please help!! Not sure if I removed GE oven heating elements properly

Started by ratdog

Replies: 3
Views: 2331
Last post May 07, 2009, 08:25:55 AM
by ratdog
GW395LEGB5 Whirlpool Gas Oven Not Heating

Started by AJ

Replies: 0
Views: 1561
Last post September 25, 2011, 08:49:01 AM
by AJ
Whirlpool Buit-In Oven - No heat

Started by AJ

Replies: 0
Views: 3710
Last post December 28, 2007, 07:41:25 AM
by AJ
Whirlpool Range Not Heating

Started by TechnicianBrian

Replies: 0
Views: 2942
Last post March 26, 2008, 12:26:47 PM
by TechnicianBrian