Author Topic: No display on Whirlpool RBD275PDQ14  (Read 1075 times)

Offline Sot

  • VIP Member
  • Member Since: Jan 2013
  • Posts: 2
No display on Whirlpool RBD275PDQ14
« on: January 20, 2013, 09:50:55 PM »
Hi folks.  Not long ago I heard a series of beeps from my kitchen (one long and four short beeps, if I remember right) and found it was my oven.  The oven seems to work fine except for the fact that the digital display is blank.  But I pulled the breaker and opened the cover, and found that one of the varistors on the suppressor board was fried.  I got a new one but while replacing that I found that one of the traces on the circuit board was completely burnt off as well, so I guess I have to replace the whole board.  :(

My fear is/was that something else is burned up.  So, I secured a wire across the burnt trace on the circuit board just so that I could power it on and verify that it would work right again after I replaced the board.  Unfortunately, still no digital display.  :tickedoff:

So what's the best way to determine whether the display has failed due to a problem on the suppressor board, the control board, or something else?  Should I just start replacing parts until the problem goes away?

Offline LowSL2

  • Technician
  • Member Since: Dec 2011
  • Posts: 851
  • Country: us
  • Fletch F. Fletch
    • Buy me a beer through paypal
Re: No display on Whirlpool RBD275PDQ14
« Reply #1 on: January 21, 2013, 01:55:13 AM »
If the display and other related components are fried, I would suspect the transformer has gone out. Part # 9760587

Sent from my DROID BIONIC using Tapatalk 2
LowSL2
15 Years of Professional Appliance Repair Experience

Offline Sot

  • VIP Member
  • Member Since: Jan 2013
  • Posts: 2
Re: No display on Whirlpool RBD275PDQ14
« Reply #2 on: January 21, 2013, 08:29:07 PM »
How would you suggest testing that?  The primary and the secondary of the transformer are not open; one's about 55 ohms and the other just a few.

Offline domain

  • Technician
  • Member Since: Nov 2012
  • Posts: 866
  • Country: us
Re: No display on Whirlpool RBD275PDQ14
« Reply #3 on: January 21, 2013, 09:12:03 PM »
How would you suggest testing that?  The primary and the secondary of the transformer are not open; one's about 55 ohms and the other just a few.
I believe 120 vac in/ 24 vdc out. :D

Offline RegUS_PatOff

  • Technician
  • Member Since: Dec 2007
  • Posts: 1410
  • Country: us
Re: No display on Whirlpool RBD275PDQ14
« Reply #4 on: January 25, 2013, 03:00:00 AM »
I believe 120 vac in/ 24 vdc out. :D
I believe 120 vac in/ 24 vAc out.  :popcorn:
« Last Edit: January 25, 2013, 03:00:27 AM by RegUS_PatOff »
After leaving this Earth, "Do you want the smoking or non-smoking section?"

Offline domain

  • Technician
  • Member Since: Nov 2012
  • Posts: 866
  • Country: us
Re: No display on Whirlpool RBD275PDQ14
« Reply #5 on: January 26, 2013, 11:47:57 AM »
I believe 120 vac in/ 24 vdc out. :D
I believe 120 vac in/ 24 vAc out.  :popcorn:

Ooooooops. Sorry!  :D

 

Whirlpool double oven display blank

Started by timpeterson75

Replies: 2
Views: 5658
Last post February 20, 2009, 09:14:06 AM
by timpeterson75
WHIRLPOOL OVEN - INTERMITTANT DISPLAY

Started by rbellr

Replies: 1
Views: 508
Last post July 12, 2013, 11:02:20 AM
by fixyourboard2
Removing main top on whirlpool gas range with sealed burners

Started by Vornato

Replies: 1
Views: 8690
Last post December 06, 2007, 07:17:47 AM
by apptech
Whirlpool Range - Top Burner Not Working

Started by AJ

Replies: 0
Views: 4034
Last post December 28, 2007, 12:21:08 AM
by AJ
Whirlpool Buit-In Oven - No heat

Started by AJ

Replies: 0
Views: 2700
Last post December 28, 2007, 07:41:25 AM
by AJ
Whirlpool Electric Range - Bake Cycle Not Working

Started by AJ

Replies: 0
Views: 3632
Last post January 01, 2008, 03:44:30 PM
by AJ