Forum > Refrigerator & Freezer Repair

Whirlpool Gold Series Refrigerator - Again

<< < (3/12) > >>

domain:
 :cheers:

iliiinieis:
Thanks. I hope it is trouble free for awhile. It runs like a champ now. The freezer got a good scrubbing too.

iliiinieis:
Ok guys, it happened again. Its completely froze up again and just as bad. There must be something wrong. I need ideas. In my previous cleaning it drained perfect and was extremely clean. For some reason it is freezing up before it drains? I am at a loss with this refrigerator.

dab147315:
That ice on the evaporator is not from a clog drain in the picture you first posted.Are your door gasket OK?Is the dispenser flap closing?Are all the fan motors working,fan in freezer and fan by compressor working.And does it have that ice on the evaporator again like in the first post or is it just the drain.

AJ:


--- Quote from: dab147315 on December 31, 2012, 06:43:33 PM ---That ice on the evaporator is not from a clog drain in the picture you first posted.Are your door gasket OK?Is the dispenser flap closing?Are all the fan motors working,fan in freezer and fan by compressor working.And does it have that ice on the evaporator again like in the first post or is it just the drain.

--- End quote ---


I agree with dab, also if it is really a drain problem there is a heater probe kit they make to clamp on the defrost element and feed down the drain hole.

http://www.repairclinic.com/PartDetail/Drain-Strap/819043/726493

I know some guys that also do the same thing with a heavy gage piece of coper wire.

Sometimes the defrost heating elements will warp up and away from the defrost pans over time.

Can't tell from your photos if that is the case or not, but I have replaced some defrost element that "worked" as far as getting hot, but had warped.

Your model uses heating element part # 2323198


Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version