Author Topic: GE defrost issues  (Read 758 times)

Offline pzubiri

  • VIP Member
  • Member Since: Sep 2012
  • Posts: 1
  • Country: py
GE defrost issues
« on: September 13, 2012, 03:36:34 PM »
Hi, I have a GE refrigerator PSG27SHSBCSS (220v) and a few weeks ago I started to have defrost issues. I checked the defrost heater for continuity and I get 85 ohms, the termistor and the thermostat seems to be OK. Is that ohms reading correct for a 220 v heater or should I replace the heater?

Note (the defrost runs OK when I start it from the temp control panel function 1 4).

I'am going to replace the main board anyway because I was getting the ice in the ice maker melted and re frosted and I read that it's due to a main board problem.

Thanks.

Offline AJ

  • Technician
    Administrator
  • Member Since: Jun 2007
  • Posts: 9396
  • Country: us
    • ApplianceJunk.com - Appliance Repair
Re: GE defrost issues
« Reply #1 on: November 11, 2012, 01:36:13 AM »
Did the main board fix it?
Hope you find our site helpful.

 

Video: How to clear a Whirlpool made Refrigerator Defrost Drain Tube.

Started by AJ

Replies: 2
Views: 18749
Last post August 11, 2007, 09:38:43 AM
by AJ
GE refrigerator defrost

Started by jumptrout51

Replies: 7
Views: 12939
Last post March 28, 2008, 02:42:31 PM
by jumptrout51
Whirlpool Refrigerator - Not running, replaced defrost timer.

Started by AJ

Replies: 0
Views: 9206
Last post May 09, 2008, 01:05:15 PM
by AJ
Initiate defrost

Started by jumptrout51

Replies: 2
Views: 2091
Last post September 18, 2008, 05:13:32 PM
by jumptrout51
Freezer will not automatically defrost

Started by CEK

Replies: 3
Views: 3533
Last post September 23, 2008, 01:39:50 PM
by JWWebster
Whirlpool ice maker stopped working after bucket defrost

Started by stream41

Replies: 23
Views: 7418
Last post December 07, 2012, 12:32:18 PM
by AJ