Author Topic: Viking burners not igniting  (Read 2335 times)

Offline michaeljc70

  • VIP Member
  • Member Since: Jul 2012
  • Posts: 23
Viking burners not igniting
« on: July 03, 2012, 01:38:16 PM »
I have a 48" viking range, about 11 years old. The left 4 burners work fine.  The other burners (grill and 2 regular burners), ignite maybe 5% of the time. I use a lighter to light them usually.

I am going to sell the house and need to fix this.  I looked at the igniter wires, and they look fine (no breaks, nicks, burn marks). I took off an ignitor and cleaned it.  Still nothing.

I am assuming it is the ignitor control module. I think this stove has 2 (1 left, 1 right).  Before ordering it, is there anything else I can do or check?   

I suppose to be REALLY sure, I could disconnect the one on the left, move it to the right and make sure it works there.  Thoughts?

Offline michaeljc70

  • VIP Member
  • Member Since: Jul 2012
  • Posts: 23
Re: Viking burners not igniting
« Reply #1 on: July 03, 2012, 04:04:21 PM »
I went ahead and swapped the non-working spark module with the working on and the burners ignited.   I just need to order a new spark module. 

It is somewhat confusing though.  The part is Harper-Wyman 6540S0001 right off the part.  When I look for my range model and spark igniters online, I get some different parts that look different. It is possible in 11 years the part changed looks wise.  I am wondering if I should just look for the part I have, or go with the new part. 

Offline AJ

  • Technician
    Administrator
  • Member Since: Jun 2007
  • Posts: 9428
  • Country: us
    • ApplianceJunk.com - Appliance Repair
Re: Viking burners not igniting
« Reply #2 on: July 03, 2012, 04:05:54 PM »
Hi,


Quote
When I look for my range model and spark igniters online, I get some different parts that look different.


and what would that model number be?
Hope you find our site helpful.

Offline michaeljc70

  • VIP Member
  • Member Since: Jul 2012
  • Posts: 23
Re: Viking burners not igniting
« Reply #3 on: July 03, 2012, 05:40:17 PM »
VGIC485-6QSS.   I think I got it figured out...I just ordered the exact part I took out....Harper-Wyman 6540 and ignored the Viking part number.

I do have a problem though.  One burner keeps clicking even after the flame is on.  I changed the igniter, same thing. Tried a different igniter wire, same thing.  I checked the grounding and connection to the spark module and they look okay.  The other burned and grill light and the igniter turns off fine.

Offline RegUS_PatOff

  • Technician
  • Member Since: Dec 2007
  • Posts: 1410
  • Country: us
Re: Viking burners not igniting
« Reply #4 on: July 04, 2012, 10:51:37 PM »
... One burner keeps clicking even after the flame is on.
only one Burner ?
if it was (2), the Ignitor wires may have been swapped ....
Check to see if it's connected to the correct input and output.
After leaving this Earth, "Do you want the smoking or non-smoking section?"

Offline michaeljc70

  • VIP Member
  • Member Since: Jul 2012
  • Posts: 23
Re: Viking burners not igniting
« Reply #5 on: July 05, 2012, 09:45:30 AM »
... One burner keeps clicking even after the flame is on.
only one Burner ?
if it was (2), the Ignitor wires may have been swapped ....
Check to see if it's connected to the correct input and output.

After playing with it more this is what I see:

Burners are (G)rill (F)ront, (B)ack

Burner F works fine.
Burner B keeps clicking unless all burners on or just F is turned on
Burner G clicks unless all burners on

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Viking burners not igniting
« Reply #6 on: July 05, 2012, 12:07:30 PM »
Spark switch for that burner prob needs to be replaced. Yank the wire off of it and see if the sparking stops is what I would do.
Note: Being careful not to get shocked or shorting out any live wires of course.
« Last Edit: July 05, 2012, 12:09:09 PM by JWWebster »
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline michaeljc70

  • VIP Member
  • Member Since: Jul 2012
  • Posts: 23
Re: Viking burners not igniting
« Reply #7 on: July 05, 2012, 12:27:40 PM »
Spark switch for that burner prob needs to be replaced. Yank the wire off of it and see if the sparking stops is what I would do.
Note: Being careful not to get shocked or shorting out any live wires of course.

I'll give that a try.

Do you know if the 3 wires (all red)  that are connected to the spark module need to go in a particular place?  Since they looked identical and weren't labelled, I assumed where I plugged them in didn't matter (I just noted wire color and put any red wire where there was a red wire before).  Could that be my problem?   

It looks like those come from the spark switch.  Originally I thought they were a power source so I thought it didn't matter.


Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Viking burners not igniting
« Reply #8 on: July 05, 2012, 01:46:03 PM »
The way that particular Harper Wyman module works is it have 2 inputs (Line and Neutral) for power in and a leg out to each burner. When power is applied they all spark at the same time. This module MUST be properly grounded. Each burner valve has a spark switch and each burner must be grounded as well. If you turn on a burner all them igniters will spark but only the valve you opened will ignite. If you have one that continues to spark then you most likely have a spark switch that has it's contacts fried together. Harper-Wyman also sells the spark switches. I used to sell Harper-Wyman as an authorized Harper-Wyman dealer.
« Last Edit: July 05, 2012, 01:53:21 PM by JWWebster »
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline michaeljc70

  • VIP Member
  • Member Since: Jul 2012
  • Posts: 23
Re: Viking burners not igniting
« Reply #9 on: July 05, 2012, 01:57:03 PM »
I pulled the wire off the spark switch on the rear burner.  When I turned on the grill, it continue to spark even after lit. The front burner worked properly as before.

My spark module on the right actually had 2 grounds. I made sure to reattach those tightly when I replaced it.  For some reason, the one on the left had only 1 ground.  The one that I am having the problem with now had a ground wire attached where all the red and black wires are, but also one that attached below the wires on the side where the igniter wires are.


Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Viking burners not igniting
« Reply #10 on: July 05, 2012, 05:31:01 PM »
What about your spark switchs? You checked them? I think you have to yank all of the knobs off and remove some screws under them so that the trimwork can be removed to get to them switches.
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

Offline michaeljc70

  • VIP Member
  • Member Since: Jul 2012
  • Posts: 23
Re: Viking burners not igniting
« Reply #11 on: July 05, 2012, 06:04:32 PM »
I swapped out the Grill and Back burner spark switch and everything was the same.

I left the front burner spark switch since that is the only one that works properly.

Thanks for the help BTW.

Offline JWWebster

  • Technician
  • Member Since: Jan 2008
  • Posts: 8780
  • Country: us
  • SublimeMasterJW
    • Buy me a beer through paypal
    • JW's Sublime Appliance Advice
Re: Viking burners not igniting
« Reply #12 on: July 05, 2012, 10:25:50 PM »
Some of them fancy stove have differing controls for grill and burners. Sound like to me like yall have some sort of potentiometer malfunction.
I could be wrong. Have been in da past. READ ALL ABOUT IT

Note: It is a big ass file linked by a redneck. Give it a minute to load before freaking out.  :rofl:
« Last Edit: July 05, 2012, 10:37:24 PM by JWWebster »
May the hinges of our friendship
        never grow rusty.

About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack. The small green square=personal message. The green dot is a link to my web page on appliance repair and other general BS I love to post. The letter sends me email.
I love fan letters! LOL

 

One of 6 burners not igniting. Viking vdsc485

Started by Becker135

Replies: 0
Views: 557
Last post January 20, 2013, 04:02:37 PM
by Becker135
2 of 4 top burners not igniting

Started by centralappliance

Replies: 4
Views: 1680
Last post July 28, 2009, 08:35:30 PM
by centralappliance
frigidaire gas stove model ffgf3053lsf burners not igniting on all four

Started by gregaguilar

Replies: 2
Views: 954
Last post July 30, 2013, 08:15:43 PM
by afterblast
Viking range - one burner not igniting

Started by michaeljc70

Replies: 5
Views: 936
Last post August 05, 2013, 04:37:09 PM
by michaeljc70
Removing main top on whirlpool gas range with sealed burners

Started by Vornato

Replies: 1
Views: 8715
Last post December 06, 2007, 07:17:47 AM
by apptech
Viking Dual Fuel Range

Started by TechnicianBrian

Replies: 0
Views: 2172
Last post April 04, 2008, 05:00:21 PM
by TechnicianBrian