Author Topic: Whirlpool Polara Range--Bake, Convect Bake, Broil and Clean--no heat-no error co  (Read 4294 times)

Offline pjgrose

  • VIP Member
  • Member Since: Jun 2012
  • Posts: 8
Bake, Broil, Clean does not work on my oven.  There are no error messages on the top control panel.  It lights up fine.  Both elements look fine and tested fine.  They are receiving current.  My husband and I have run the voltage tester on every part you can imagine.  Everything shows ok except when he tests the electronic control board on the side of the range.  The red, blue and yellow wires showed no reading, but the others in that plug did show a current.  There was a smudged black area around the ground wire port on the electronic control board.  The in-line fuse if fine.  The oven clicks like it is trying to come on but never heats up. Tester showed current getting to the control panel.  It looks like the electronic control board on the side has been replaced before.  In going through the paperwork, it looks like this oven was a return/used.  It was presented to us as a closeout model and new when we purchased it in 2004.  I just discovered a yellow sticker on back of the closeout sign that said used. >:(  Any suggestions on what to replace would be much appreciated.

Offline AJ

  • Technician
    Administrator
  • Member Since: Jun 2007
  • Posts: 9606
  • Country: us
    • ApplianceJunk.com - Appliance Repair
Hi,

It would be helpful if you could post the model number from the model/serial number tag that located on the range.

Are you using a multimeter to check for voltage or just a lighted voltage tester?
Hope you find our website helpful.

Offline pjgrose

  • VIP Member
  • Member Since: Jun 2012
  • Posts: 8
Model # GR556LRKC0.  Used a multimeter to test.  Parts I am not sure which or if to replace Control Panel #9782613, or Electronic Control #8523034 or #6610333 (same part manufacturer replaced 3034 with 0333)

Offline AJ

  • Technician
    Administrator
  • Member Since: Jun 2007
  • Posts: 9606
  • Country: us
    • ApplianceJunk.com - Appliance Repair
When I look up model GR556LRKC0 it calls for control part # 8190770

How did you come up with the other part numbers?
Hope you find our website helpful.

Offline pjgrose

  • VIP Member
  • Member Since: Jun 2012
  • Posts: 8
Its the same part...my manual is old.

Offline RegUS_PatOff

  • Technician
  • Member Since: Dec 2007
  • Posts: 1410
  • Country: us
 
...  They are receiving current. 
... voltage tester on every part you can imagine. 
I think you have current and voltage confused.
They are different ..
Did you test the (3) Thermal Safety Devices ?
(I'm not sure which one is for the Bake / Broil)
# 12, # 17, # 21

After leaving this Earth, "Do you want the smoking or non-smoking section?"

Offline tgoods

  • Technician
    Moderator
  • Member Since: Jul 2010
  • Posts: 1527
  • Country: us
    • Buy me a beer through paypal
Check your DLB relay.  It's the big relay with two red wires.  With the oven on, check for a voltage drop across the terminals.  0 VAC is good, 240 VAC is bad. 

Offline pjgrose

  • VIP Member
  • Member Since: Jun 2012
  • Posts: 8
Where is the DLB relay located?  We could not identify it on the parts list in the manual. We are new to this, but trying to fix my range to prepare a rehersal dinner for my son's wedding next Friday night.  Thanks for your patience. 

Offline pjgrose

  • VIP Member
  • Member Since: Jun 2012
  • Posts: 8
If I am right it is the black square box located on the manager board in front of the range.  It read 241  ACV on our digital multimeter.  Can this be replaced without replacing the whole board? Part #9782613 aka #8190770  which is #10 on control panel parts in manual.

Offline tgoods

  • Technician
    Moderator
  • Member Since: Jul 2010
  • Posts: 1527
  • Country: us
    • Buy me a beer through paypal
If you have soldering skills, you can try just replacing the relay.  There should be some numbers on the relay. I can usually find them at mouser.com.  Another option is to have the board rebuilt at fixyourboard.com or corecentricsolutions.com

 

whirlpool gas range bake and broil not lighting

Started by mike k

Replies: 6
Views: 5391
Last post November 22, 2010, 01:51:03 AM
by RegUS_PatOff
Whirlpool Range RF364PXYQ2 oven does not heat during the bake cycle

Started by AJ

Replies: 0
Views: 1532
Last post January 04, 2012, 05:08:51 PM
by AJ
Whirlpool Electric Range - Bake Cycle Not Working

Started by AJ

Replies: 0
Views: 4191
Last post January 01, 2008, 03:44:30 PM
by AJ
Whirlpool Range Bake Element Not Heating

Started by TechnicianBrian

Replies: 0
Views: 2512
Last post April 08, 2008, 07:08:16 AM
by TechnicianBrian
Frigidaire Range no Bake or Broil

Started by TechnicianBrian

Replies: 0
Views: 3403
Last post May 13, 2008, 09:48:19 PM
by TechnicianBrian
Hotpoint Range no Bake or Broil

Started by TechnicianBrian

Replies: 0
Views: 2567
Last post May 18, 2008, 07:42:18 AM
by TechnicianBrian